]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
start update to 0.57
[packages/pidgin.git] / pidgin.spec
1 # This file does not like to be adapterized!
2 Summary:        A client compatible with AOL's 'Instant Messenger'
3 Summary(pl):    Klient kompatybilny z AOL Instant Messenger
4 Summary(pt_BR): Um cliente para o AOL Instant Messenger (AIM)
5 Name:           gaim
6 Version:        0.57
7 Release:        0.1
8 Epoch:          1
9 License:        GPL
10 Group:          Applications/Communications
11 Source0:        http://prdownloads.sourceforge.net/gaim/%{name}-%{version}.tar.bz2
12 Patch0:         %{name}-gg_logoff.patch
13 Patch1:         %{name}-AC_LIBOBJ.patch
14 Patch2:         %{name}-am_ac.patch
15 URL:            http://gaim.sourceforge.net/
16 BuildRequires:  ORBit-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gnome-libs-devel >= 1.2.13
20 BuildRequires:  esound-devel
21 BuildRequires:  gtk+-devel >= 1.2.5
22 BuildRequires:  gettext-devel
23 BuildRequires:  libtool
24 BuildRequires:  perl-devel
25 BuildRequires:  gnome-core-devel
26 BuildRequires:  gdk-pixbuf-devel
27 Requires:       applnk
28 Requires:       gaim-ui = %{version}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _prefix         /usr/X11R6
32 %define         _sysconfdir     /etc/X11/GNOME
33 %define         _mandir         %{_prefix}/man
34
35 %description
36 Gaim allows you to talk to anyone using AOL's Instant Messenger
37 service (you can sign up at http://www.aim.aol.com). It uses the TOC
38 version of the AOL protocol, so your buddy list is stored on AOL's
39 servers and can be retrieved from anywhere. It contains many of the
40 same features as AOL's IM client while at the same time incorporating
41 many new features. Gaim also contains a multiple connection feature
42 which consists of protocol plugins. These plugins allow you to use
43 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
44 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
45
46 %description -l pl
47 Gaim pozwala na rozmowy z dowoln± osob± u¿ywaj±c± us³ugi AOL Instant
48 Messenger (mo¿na siê zarejstrowaæ pod adresem
49 http://www.aim.aol.com/). Program u¿ywa wersji TOC protoko³u AOL wiêc
50 Twoja lista kontaktów jest zapisana na serwerze AOL i mo¿e byc
51 przes³ana gdziekolwiek. Gaim zawiera wiele udogodnieñ dostêpnych w
52 kliencie AOL IM jak równie¿ dodaje w³asne. Gaim umo¿liwia tak¿e dostêp
53 do us³ug takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
54 oraz Gadu-Gadu.
55
56 %description -l pt_BR
57 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
58 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
59 características do cliente da AOL, tendo uma interface similiar.
60 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
61 MSN, Jabber e Napster.
62
63 %package ui-gtk
64 Summary:        gtk+ user interface for gaim
65 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z gtk+
66 Group:          Applications/Communications
67 Provides:       gaim-ui = %{version}-%{release}
68
69 %description ui-gtk
70 gtk+ user interface for gaim.
71
72 %description ui-gtk -l pl
73 Interfejs u¿ytkownika gaim korzystaj±cy z gtk+.
74
75 %package ui-gnome
76 Summary:        GNOME user interface for gaim (applet)
77 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet)
78 Group:          Applications/Communications
79 Provides:       gaim-ui = %{version}-%{release}
80
81 %description ui-gnome
82 GNOME user interface for gaim (applet).
83
84 %description ui-gnome -l pl
85 Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet).
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 rm -f missing
95 libtoolize --copy --force
96 gettextize --copy --force
97 aclocal -I m4
98 autoheader
99 autoconf
100 automake -a -c -f
101 %configure \
102         --disable-panel \
103         --enable-esd \
104         --disable-nas \
105         --disable-artsc \
106         --disable-gnome \
107         --with-gtk-prefix=/usr/X11R6 \
108         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
109 %{__make} 
110 mv plugins/iconaway{,_standalone}.so
111 mv src/gaim{,_standalone}
112 %{__make} clean
113
114 %configure \
115         --enable-panel \
116         --enable-esd \
117         --disable-nas \
118         --disable-artsc \
119         --enable-gnome \
120         --with-gtk-prefix=/usr/X11R6 \
121         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
122 %{__make}
123         
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 # NOTE: make ignores gaimdesktopdir set below.
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         gaimdesktopdir=%{_applnkdir}/Network/Communications \
131         distribdesktopdir=%{_applnkdir}/Network/Communications
132
133 mv $RPM_BUILD_ROOT{%{_datadir}/gnome/apps/Internet/gaim.desktop,%{_applnkdir}/Network/Communications}
134
135 mv $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway{,_applet}.so
136 install plugins/iconaway_standalone.so $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway.so
137 install src/gaim_standalone $RPM_BUILD_ROOT%{_bindir}/gaim
138
139 gzip -9nf AUTHORS ChangeLog NEWS README* TODO HACKING \
140         doc/{CREDITS,FAQ}
141
142 %find_lang %{name} --with-gnome --all-name
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc {*,doc/*}.gz
150 %dir %{_libdir}/gaim
151 %attr(755,root,root) %{_libdir}/gaim/[^i]*.so
152 %{_pixmapsdir}/*
153 %{_mandir}/man?/*
154
155 %files ui-gtk
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/gaim
158 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
159 %{_applnkdir}/Network/Communications/gaim.desktop
160
161 %files ui-gnome
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/gaim_applet
164 %attr(755,root,root) %{_libdir}/gaim/iconaway_applet.so
165 %{_applnkdir}/Network/Communications/gaim_applet.desktop
166 %{_sysconfdir}/CORBA/servers/*
This page took 0.125125 seconds and 3 git commands to generate.