]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
- up to version 1.0.2
[packages/pidgin.git] / pidgin.spec
1 # This file does not like to be adapterized!
2 ###########
3 %bcond_without  doc             # do not generate and include documentation
4 %bcond_without  gtkspell        # without gtkspell support
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        A client compatible with AOL's 'Instant Messenger'
8 Summary(ko):    AOL ÀνºÅÏÆ® ¸Þ½ÅÀú¿Í È£È¯µÇ´Â Å¬¶óÀ̾ðÆ®
9 Summary(pl):    Klient kompatybilny z AOL Instant Messenger
10 Summary(pt_BR): Um cliente para o AOL Instant Messenger (AIM)
11 Name:           gaim
12 Version:        1.0.2
13 Release:        1
14 Epoch:          1
15 License:        GPL
16 Group:          Applications/Communications
17 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
18 # Source0-md5:  80fbe23c6206ca6c0c62c30d5091d7e4
19 Patch0:         %{name}-nolibs.patch
20 Patch1:         %{name}-desktop.patch
21 Patch2:         %{name}-GG-evo.patch
22 Patch3:         %{name}-locale_names.patch
23 Patch4:         %{name}-po.patch
24 URL:            http://gaim.sourceforge.net/
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  evolution-data-server >= 0.0.95
29 BuildRequires:  gettext-devel
30 BuildRequires:  gtk+2-devel >= 1:2.2.0
31 %{?with_gtkspell:BuildRequires: gtkspell-devel >= 2.0.4}
32 BuildRequires:  libao-devel
33 BuildRequires:  libtool
34 BuildRequires:  perl-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  xcursor-devel
37 %if %{with doc}
38 BuildRequires:  doxygen
39 BuildRequires:  graphviz
40 %endif
41 Requires:       gaim-ui = %{epoch}:%{version}-%{release}
42 #Requires:      libao
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Gaim allows you to talk to anyone using AOL's Instant Messenger
47 service (you can sign up at http://www.aim.aol.com). It uses the TOC
48 version of the AOL protocol, so your buddy list is stored on AOL's
49 servers and can be retrieved from anywhere. It contains many of the
50 same features as AOL's IM client while at the same time incorporating
51 many new features. Gaim also contains a multiple connection feature
52 which consists of protocol plugins. These plugins allow you to use
53 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
54 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
55
56 %description -l pl
57 Gaim pozwala na rozmowy z dowoln± osob± u¿ywaj±c± us³ugi AOL Instant
58 Messenger (mo¿na siê zarejestrowaæ pod adresem
59 http://www.aim.aol.com/). Program u¿ywa wersji TOC protoko³u AOL wiêc
60 Twoja lista kontaktów jest zapisana na serwerze AOL i mo¿e byc
61 przes³ana gdziekolwiek. Gaim zawiera wiele udogodnieñ dostêpnych w
62 kliencie AOL IM jak równie¿ dodaje w³asne. Gaim umo¿liwia tak¿e dostêp
63 do us³ug takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
64 oraz Gadu-Gadu.
65
66 %description -l pt_BR
67 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
68 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
69 características do cliente da AOL, tendo uma interface similiar.
70 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
71 MSN, Jabber e Napster.
72
73 %package ui-gtk
74 Summary:        gtk+ user interface for gaim
75 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z gtk+
76 Group:          Applications/Communications
77 Provides:       gaim-ui = %{epoch}:%{version}-%{release}
78
79 %description ui-gtk
80 gtk+ user interface for gaim.
81
82 %description ui-gtk -l pl
83 Interfejs u¿ytkownika gaim korzystaj±cy z gtk+.
84
85 %package devel
86 Summary:        Development files for gaim-remote library
87 Summary(pl):    Pliki programistyczne biblioteki gaim-remote
88 Group:          Development/Libraries
89 Requires:       %{name} = %{epoch}:%{version}-%{release}
90 Requires:       glib2-devel >= 2.0.0
91
92 %description devel
93 Development files for gaim-remote library.
94
95 %description devel -l pl
96 Pliki programistyczne biblioteki gaim-remote.
97
98 %package perl
99 Summary:        Gaim files for perl scripts
100 Summary(pl):    Pliki Gaim dla skryptów perl
101 Group:          Development/Libraries
102 Requires:       %{name} = %{epoch}:%{version}-%{release}
103
104 %description perl
105 Gaim files for perl scripts.
106
107 %description perl -l pl
108 Pliki Gaim dla skryptów perl.
109
110 %package doc
111 Summary:        Gaim documentation for developers (HTML format)
112 Summary(pl):    Dokumentacja Gaim dla programistów (format HTML)
113 Group:          Development/Libraries
114
115 %description doc
116 Gaim documentation for developers (HTML format).
117
118 %description doc -l pl
119 Dokumentacja Gaim dla programistów (format HTML).
120
121 %prep
122 %setup -q 
123 %patch0 -p1
124 %patch1 -p1
125 %patch2 -p1
126 %patch3 -p1
127 mv -f po/{no,nb}.po
128
129 %patch4 -p1
130
131 %build
132 %{__libtoolize}
133 %{__gettextize}
134 %{__aclocal}
135 %{__autoheader}
136 %{__autoconf}
137 %{__automake}
138 %configure \
139         --disable-nas \
140         --enable-nss=no \
141         --with-perl-lib=vendor \
142         %{!?with_gtkspell:--disable-gtkspell}
143
144 %{__make}
145 %{?with_doc:%{__make} docs}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 rm -f $RPM_BUILD_ROOT%{_libdir}/gaim/*.la
154
155 %find_lang %{name} --with-gnome --all-name
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog NEWS README* HACKING doc/{CREDITS,FAQ}
166 %attr(755,root,root) %{_bindir}/gaim-remote
167 %attr(755,root,root) %{_libdir}/libgaim-remote.so.0.0.0
168 %dir %{_libdir}/gaim
169 %attr(755,root,root) %{_libdir}/gaim/[!i]*.so
170 %attr(755,root,root) %{_libdir}/gaim/idle*.so
171 %{_pixmapsdir}/*
172 %{_mandir}/man?/*
173 %{_datadir}/sounds/%{name}
174
175 %files ui-gtk
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_bindir}/gaim
178 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
179 %{_desktopdir}/gaim.desktop
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libgaim-remote.so
184 %{_libdir}/libgaim-remote.la
185 %dir %{_includedir}/gaim
186 %{_includedir}/gaim/*.h
187 %{_pkgconfigdir}/*
188
189 %files perl
190 %defattr(644,root,root,755)
191 %{perl_vendorarch}/*.pm
192 %dir %{perl_vendorarch}/auto/Gaim
193 %{perl_vendorarch}/auto/Gaim/*.ix
194 %{perl_vendorarch}/auto/Gaim/*.bs
195 %attr(755,root,root) %{perl_vendorarch}/auto/Gaim/*.so
196
197 %if %{with doc}
198 %files doc
199 %defattr(644,root,root,755)
200 %doc doc/html/*.{html,png,css}
201 %endif
This page took 0.073487 seconds and 3 git commands to generate.