]> git.pld-linux.org Git - packages/picard.git/blob - picard.spec
5aca1e6c63f2530f722b82738bea9be8ade7a875
[packages/picard.git] / picard.spec
1 # TODO:
2 # - unpackaged files:
3 #   /usr/share/icons/picard-16.png
4 #   /usr/share/icons/picard-32.png
5 Summary:        Picard, the Next-Generation MusicBrainz Tagger
6 Summary(pl.UTF-8):      Picard - znaczniki MusicBrainz nowej generacji
7 Name:           picard
8 Version:        0.12.1
9 Release:        3
10 License:        GPL v2+
11 Group:          Applications
12 Source0:        ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/%{name}-%{version}.tar.gz
13 # Source0-md5:  cfe594d68924afbc0704888130295c85
14 Patch0:         %{name}-desktop.patch
15 URL:            http://musicbrainz.org/doc/PicardTagger
16 BuildRequires:  gettext-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.219
21 Requires(post,postun):  gtk-update-icon-cache
22 Requires(post,postun):  hicolor-icon-theme
23 Requires:       python-PyQt4
24 Requires:       python-musicbrainz2
25 Requires:       python-mutagen
26 Requires:       python-tunepimp
27 Requires:       python-wxPython
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The project code-named Picard is the next generation MusicBrainz
32 tagging application. This new tagging concept is Release oriented, as
33 opposed to track oriented like the ClassicTagger was. Picard is
34 written in Python, which is a cross-platform language - this allows
35 the same code to run both on Windows and on Linux. Before too long we
36 will add Mac OS X support as well.
37
38 %description -l pl.UTF-8
39 Projekt o nazwie Picard jest programem nowej generacji do generowania
40 znaczników MusicBranz. Picard jest napisany w Pythonie, który jest
41 językiem cross-platform - co pozwala uruchamiać ten sam kod zarówno
42 pod Windows jak i Linuksem. Niedługo zostanie dodana obsługa Mac OS X.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %build
49 find -type f -exec sed -i -e 's|#!.*python.*|#!%{_bindir}/python|g' "{}" ";"
50 python ./setup.py build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
55
56 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
57
58 # Scots unsupported by glibc
59 rm -r $RPM_BUILD_ROOT/%{_datadir}/locale/sco
60
61 %py_postclean
62 %find_lang %{name}
63
64 %post
65 %update_icon_cache hicolor
66
67 %postun
68 %update_icon_cache hicolor
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files -f %{name}.lang
74 %defattr(644,root,root,755)
75 %doc AUTHORS.txt NEWS.txt
76 %attr(755,root,root) %{_bindir}/%{name}
77 %{py_sitedir}/picard
78 %{py_sitedir}/%{name}-%{version}-py*.egg-info
79 %{_desktopdir}/%{name}.desktop
80 %{_iconsdir}/hicolor/*/apps/picard.png
This page took 0.036142 seconds and 3 git commands to generate.