]> git.pld-linux.org Git - packages/picard.git/blob - picard.spec
1708329cbd310bb652b4f8eda3f7900c189b94fb
[packages/picard.git] / picard.spec
1 # TODO:
2 # - unpackaged files:
3 #   /usr/share/icons/picard-16.png
4 #   /usr/share/icons/picard-32.png
5 Summary:        Picard, the Next-Generation MusicBrainz Tagger
6 Summary(pl.UTF-8):      Picard - znaczniki MusicBrainz nowej generacji
7 Name:           picard
8 Version:        0.11
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications
12 Source0:        ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/%{name}-%{version}.tar.gz
13 # Source0-md5:  02ddcff3e201b2cf54f1b52b02d44fad
14 Patch0:         %{name}-desktop.patch
15 URL:            http://musicbrainz.org/doc/PicardTagger
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 Requires:       python-PyQt4
20 Requires:       python-musicbrainz2
21 Requires:       python-tunepimp
22 Requires:       python-wxPython
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The project code-named Picard is the next generation MusicBrainz
27 tagging application. This new tagging concept is Release oriented, as
28 opposed to track oriented like the ClassicTagger was. Picard is
29 written in Python, which is a cross-platform language - this allows
30 the same code to run both on Windows and on Linux. Before too long we
31 will add Mac OS X support as well.
32
33 %description -l pl.UTF-8
34 Projekt o nazwie Picard jest programem nowej generacji do generowania
35 znaczników MusicBranz. Picard jest napisany w Pythonie, który jest
36 językiem cross-platform - co pozwala uruchamiać ten sam kod zarówno
37 pod Windows jak i Linuksem. Niedługo zostanie dodana obsługa Mac OS X.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42
43 %build
44 find -type f -exec sed -i -e 's|#!.*python.*|#!%{_bindir}/python|g' "{}" ";"
45 python ./setup.py build
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
50
51 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
52
53 install %{name}.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
54 install %{name}-32.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
55
56 %py_postclean
57 %find_lang %{name}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files -f %{name}.lang
63 %defattr(644,root,root,755)
64 %doc AUTHORS.txt NEWS.txt
65 %attr(755,root,root) %{_bindir}/%{name}
66 %{py_sitedir}/picard
67 %{py_sitedir}/%{name}-%{version}-py*.egg-info
68 %{_desktopdir}/%{name}.desktop
69 %{_pixmapsdir}/%{name}.png
This page took 0.059435 seconds and 2 git commands to generate.