]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- nicer version. add info about Ra
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - convert to webapps
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl):    phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        2.7.0
7 %define         _pl     pl1
8 # release 2 (1 is for Ra)
9 %define         _rel 2
10 Release:        %{_pl}.%{_rel}
11 License:        GPL v2
12 Group:          Applications/Databases/Interfaces
13 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-%{_pl}.tar.bz2
14 # Source0-md5:  39bfebd35f9a2de03504812df173f27d
15 #Source0:       http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}.tar.bz2
16 Source1:        %{name}.conf
17 Patch0:         %{name}-config.patch
18 URL:            http://www.phpmyadmin.net/
19 Requires(postun):       perl-base
20 Requires:       php
21 Requires:       php-mysql
22 Requires:       php-pcre
23 Requires:       webserver
24 #Suggests:      php-mbstring
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _myadmindir     %{_datadir}/%{name}
29 %define         _sysconfdir     /etc/%{name}
30
31 %description
32 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
33 but also a single database. To accomplish the latter you'll need a
34 properly set up MySQL-user who can read/write only the desired
35 database. It's up to you to look up the appropiate part in the MySQL
36 manual. Currently phpMyAdmin can:
37 - create and drop databases
38 - create, copy, drop and alter tables
39 - delete, edit and add fields
40 - execute any SQL-statement, even batch-queries
41 - manage keys on fields
42 - load text files into tables
43 - create (*) and read dumps of tables
44 - export (*) and import data to CSV values
45 - administer multiple servers and single databases
46 - communicate in more than 20 different languages
47
48 %description -l pl
49 phpMyAdmin potrafi zarz±dzaæ ca³ymi bazami MySQL (potrzebne
50 uprawnienia superu¿ytkownika) jak i pojedynczymi bazami danych.
51 Potrzebny jest u¿ytkownik, który ma prawa zapisu/odczytu tylko tych
52 baz, którymi chcemy administrowaæ (wiêcej informacji w odpowiedniej
53 podrêcznika MySQL). Aktualnie phpMyAdmin potrafi:
54 - tworzyæ i usuwaæ bazy
55 - wykonywaæ create, copy, drop oraz alter na tabelach
56 - dodawaæ, usuwaæ i modyfikowaæ pola
57 - wykonywaæ dowolne zapytania SQL
58 - zarz±dzaæ kluczami na rekordach
59 - wczytywaæ tekst z plików do tabel
60 - obs³ugiwaæ ponad 20 jêzyków
61 - zarz±dzaæ wieloma serwerami i pojedynczymi bazami danych
62 - eksportowaæ i importowaæ dane do warto¶ci CSV
63 - tworzyæ i czytaæ zrzuty tabel
64
65 %prep
66 #%setup -q
67 %setup -q -n %{name}-%{version}-%{_pl}
68 %patch -p1
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT%{_myadmindir}/{css,lang,libraries/{auth,export,dbg,dbi,transformations}} \
73         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/httpd}
74
75 install *.php *.html *.css $RPM_BUILD_ROOT%{_myadmindir}
76 install lang/*.php $RPM_BUILD_ROOT%{_myadmindir}/lang
77 cp -rf themes $RPM_BUILD_ROOT%{_myadmindir}
78 install css/* $RPM_BUILD_ROOT%{_myadmindir}/css
79 install libraries/*.{js,php} $RPM_BUILD_ROOT%{_myadmindir}/libraries
80 install libraries/auth/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/auth
81 install libraries/export/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/export
82 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbg
83 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbi
84 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/transformations
85
86 cp -rf scripts $RPM_BUILD_ROOT%{_myadmindir}
87
88 install config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
89 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_myadmindir}/config.inc.php
90
91 install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*%{name}.conf" /etc/httpd/httpd.conf; then
98         echo "Include /etc/httpd/%{name}.conf" >> /etc/httpd/httpd.conf
99         if [ -f /var/lock/subsys/httpd ]; then
100                 /usr/sbin/apachectl restart 1>&2
101         fi
102 elif [ -d /etc/httpd/httpd.conf ]; then
103         ln -sf /etc/httpd/%{name}.conf /etc/httpd/httpd.conf/99_%{name}.conf
104         if [ -f /var/lock/subsys/httpd ]; then
105                 /usr/sbin/apachectl restart 1>&2
106         fi
107 fi
108
109 %preun
110 if [ "$1" = "0" ]; then
111         umask 027
112         if [ -d /etc/httpd/httpd.conf ]; then
113                 rm -f /etc/httpd/httpd.conf/99_%{name}.conf
114         else
115                 grep -v "^Include.*%{name}.conf" /etc/httpd/httpd.conf > \
116                         /etc/httpd/httpd.conf.tmp
117                 mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
118         fi
119         if [ -f /var/lock/subsys/httpd ]; then
120                 /usr/sbin/apachectl restart 1>&2
121         fi
122 fi
123
124 %triggerpostun -- phpMyAdmin <= 2.5.3-2
125 if [ -f /home/services/httpd/html/myadmin/config.inc.php.rpmsave ]; then
126         mv -f /home/services/httpd/html/myadmin/config.inc.php.rpmsave /etc/phpMyAdmin/config.inc.php
127 else
128         if [ -f /home/httpd/html/myadmin/config.inc.php.rpmsave ]; then
129                 mv -f /home/httpd/html/myadmin/config.inc.php.rpmsave /etc/phpMyAdmin/config.inc.php
130         fi
131 fi
132 for i in `grep -lr "/home/\(services/\)*httpd/html/myadmin" /etc/httpd/*`; do
133         cp $i $i.backup
134         %{__perl} -pi -e "s#/home/httpd/html/myadmin#%{_myadmindir}#g" $i
135         %{__perl} -pi -e "s#/home/services/httpd/html/myadmin#%{_myadmindir}#g" $i
136         echo "File changed by trigger: $i (backup: $i.backup)"
137 done
138 if [ -f /var/lock/subsys/httpd ]; then
139         /usr/sbin/apachectl restart 1>&2
140 fi
141
142 %files
143 %defattr(644,root,root,755)
144 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts
145 %dir %{_sysconfdir}
146 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
147 %config(noreplace) %verify(not md5 mtime size) /etc/httpd/%{name}.conf
148 %dir %{_myadmindir}
149 %{_myadmindir}/css
150 %{_myadmindir}/themes
151 %{_myadmindir}/scripts
152 %{_myadmindir}/lang
153 %{_myadmindir}/libraries
154 %{_myadmindir}/*.css
155 %{_myadmindir}/*.html
156 %{_myadmindir}/*.php
This page took 0.047772 seconds and 4 git commands to generate.