]> git.pld-linux.org Git - SPECS.git/blob - php4-pecl-memcache.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / php4-pecl-memcache.spec
1 %define         _modname        memcache
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php4
4 %define         extensionsdir   %{_libdir}/php4
5 Summary:        %{_modname} - a memcached extension
6 Summary(pl.UTF-8):      %{_modname} - rozszerzenie memcached
7 Name:           php4-pecl-%{_modname}
8 Version:        1.5
9 Release:        4
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
13 # Source0-md5:  f521dd4d3cad4ccb05d9ade4e1cc04d4
14 URL:            http://pecl.php.net/package/memcached/
15 BuildRequires:  php4-devel >= 3:4.3.3
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 Requires:       php4-common >= 3:4.4.0-3
18 %{?requires_php_extension}
19 Obsoletes:      php4-pear-%{_modname}
20 Conflicts:      php4-mcache
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Memcached is a caching daemon designed especially for dynamic web
25 applications to decrease database load by storing objects in memory.
26
27 This extension allows you to work with memcached through handy OO and
28 procedural interfaces.
29
30 In PECL status of this extension is: %{_status}.
31
32 %description -l pl.UTF-8
33 Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
34 daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
35 przez przechowywanie w pamięci obiektów.
36
37 To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
38 zorientowanego obiektowo (oraz przez procedury) interfejsu.
39
40 To rozszerzenie ma w PECL status: %{_status}.
41
42 %prep
43 %setup -q -c
44
45 %build
46 cd %{_modname}-%{version}
47 phpize
48 %configure \
49         --with-zlib-dir=/usr
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
55
56 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
57 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
58 ; Enable %{_modname} extension module
59 extension=%{_modname}.so
60 EOF
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %php4_webserver_restart
67
68 %postun
69 if [ "$1" = 0 ]; then
70         %php4_webserver_restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc %{_modname}-%{version}/{CREDITS,README,example.php}
76 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
77 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.609621 seconds and 3 git commands to generate.