]> git.pld-linux.org Git - packages/php.git/blob - php.spec
first try to new php layout
[packages/php.git] / php.spec
1 #
2 #   oracle - with oracle support 
3 #   oci8   - with oci8 support
4 #       
5 Summary:        The PHP HTML-embedded scripting language for use with Apache
6 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache
7 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache
8 Name:           php
9 Version:        4.0.4pl1
10 Release:        0.4
11 Epoch:          1
12 Group:          Libraries
13 Group(de):      Libraries
14 Group(fr):      Librairies
15 Group(pl):      Biblioteki
16 License:        The PHP license (see "LICENSE" file included in distribution)
17 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
18 Source1:        FAQ.php
19 Source2:        %{name}.ini
20 Source3:        zend.gif
21 Source4:        http://www.php.net/distributions/manual.tar.gz
22 Source5:        php-module-install
23 Patch0:         %{name}-imap.patch
24 Patch1:         %{name}-mysql-socket.patch
25 Patch2:         %{name}-mail.patch
26 Patch5:         %{name}-no_libnsl.patch
27 Patch6:         %{name}-DESTDIR.patch
28 Patch7:         %{name}-gd-shared.patch
29 Patch8:         %{name}-apache-fixes.patch
30 #Patch9:                %{name}-system-expat.patch
31 Icon:           php4.gif
32 URL:            http://www.php.net/
33 BuildRequires:  apache(EAPI)-devel
34 BuildRequires:  zip
35 BuildRequires:  bison
36 BuildRequires:  flex
37 BuildRequires:  db3-devel >= 3.1.17
38 BuildRequires:  freetype-devel
39 BuildRequires:  gd-devel >= 1.8.3
40 BuildRequires:  gdbm-devel
41 BuildRequires:  imap-devel >= 4.7b-1
42 # I think jdk is better for java
43 # BuildRequires:        jdk
44 %{?bcond_on_java:BuildRequires: kaffe-devel}
45 BuildRequires:  libjpeg-devel
46 BuildRequires:  libltdl-devel
47 BuildRequires:  libpng >= 1.0.8
48 BuildRequires:  libtiff-devel
49 BuildRequires:  mm-devel >= 1.1.3
50 %{!?bcond_off_ldap:BuildRequires: openldap-devel >= 2.0}
51 BuildRequires:  pam-devel
52 BuildRequires:  pdflib-devel >= 3.0
53 #BuildRequires: libxml-devel >= 2.0.0
54 BuildRequires:  postgresql-devel
55 BuildRequires:  recode-devel >= 3.5
56 BuildRequires:  t1lib-devel
57 BuildRequires:  unixODBC-devel
58 BuildRequires:  zlib-devel >= 1.0.9
59 BuildRequires:  ucd-snmp-devel >= 4.1
60 BuildRequires:  libmcrypt-devel >= 2.4.4
61 BuildRequires:  mhash-devel
62 BuildRequires:  bzip2-devel
63 BuildRequires:  gmp-devel
64 BuildRequires:  curl-devel
65 %if %(expr %{?bcond_on_openssl:1}%{!?bcond_on_openssl:0} + %{!?bcond_off_ldap:1}%{?bcond_off_ldap:0})
66 BuildRequires:  openssl-devel >= 0.9.6
67 %endif
68 Requires:       apache(EAPI) >= 1.3.9
69 Prereq:         perl
70 Prereq:         /usr/sbin/apxs
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _sysconfdir     /etc/php
74 %define         extensionsdir   %{_libdir}/php/extensions/no-debug-non-zts-%(egrep '#define ZEND_MODULE_API_NO ' %{_builddir}/%{buildsubdir}/Zend/modules.h|sed 's/#define ZEND_MODULE_API_NO //')
75
76 %description
77 PHP is an HTML-embedded scripting language. PHP attempts to make it
78 easy for developers to write dynamically generated web pages. PHP also
79 offers built-in database integration for several commercial and
80 non-commercial database management systems, so writing a
81 database-enabled web page with PHP is fairly simple. The most common
82 use of PHP coding is probably as a replacement for CGI scripts. The
83 mod_php module enables the Apache web server to understand and process
84 the embedded PHP language in web pages. This package contains PHP
85 version %{version}. If you use applications which specifically rely on
86 PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
87 module contained in the phpfi package. If you're just starting with
88 PHP, you should install this package. You'll also need to install the
89 Apache web server.
90
91 %description -l fr
92 PHP est un langage de script embarque dans le HTM. PHP essaye de
93 rendre simple aux developpeurs d'ecrire des pages web generees
94 dynamiquement. PHP incorpore egalement une integration avec plusieurs
95 systemes de gestion de bases de donnees commerciaux et
96 non-connerciaux, qui rent facile la creation de pages web liees avec
97 des bases de donnees. L'utilisation la plus commune de PHP est
98 probablement en remplacement de scripts CGI. Le module mod_php permet
99 au serveur web apache de comprendre et de traiter le langage PHP
100 integre dans des pages web. Ce package contient PHP version
101 %{version}. Si vous utilisez des applications qui utilisent
102 specifiquement PHP/FI, vous devrez installer le module PHP/FI inclus
103 dans le package mod_php. Si vous debutez avec PHP, vous devriez
104 installer ce package. Vous aurez egalement besoin d'installer le
105 serveur web Apache.
106
107 %description -l pl
108 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w
109 plikach HTML. Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP
110 (jak np. Apache), który interpretuje te polecenia. Umo¿liwia to
111 tworzenie dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona
112 zosta³a z jêzyków: C, Java i Perl.
113
114 %package mysql
115 Summary:        MySQL database module for PHP
116 Summary(pl):    Modu³ bazy danych MySQL dla PHP
117 Group:          Libraries
118 Group(de):      Libraries
119 Group(fr):      Librairies
120 Group(pl):      Biblioteki
121 PreReq: %{name} = %{version}
122
123 %description mysql
124 This is a dynamic shared object (DSO) for Apache that will add MySQL
125 database support to PHP. If you need back-end support for MySQL, you
126 should install this package in addition to the main %{name} package.
127
128 %description mysql -l pl
129 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych MySQL.
130
131
132 %package pgsql
133 Summary:        PostgreSQL database module for PHP
134 Summary(pl):    Modu³ bazy danych PostgreSQL dla PHP
135 Group:          Libraries
136 Group(de):      Libraries
137 Group(fr):      Librairies
138 Group(pl):      Biblioteki
139 PreReq: %{name} = %{version}
140
141 %description pgsql
142 This is a dynamic shared object (DSO) for Apache that will add
143 PostgreSQL database support to PHP. If you need back-end support for
144 PostgreSQL, you should install this package in addition to the main
145 %{name} package.
146
147 %description pgsql -l pl
148 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych PostgreSQL.
149
150 %package oci8
151 Summary:        Oracle 8 database module for PHP
152 Summary(pl):    Modu³ bazy danych Oracle 8 dla PHP
153 Group:          Libraries
154 Group(de):      Libraries
155 Group(fr):      Librairies
156 Group(pl):      Biblioteki
157 PreReq: %{name} = %{version}
158 Autoreq:        false
159
160 %description oci8
161 This is a dynamic shared object (DSO) for Apache that will add Oracle
162 8 database support to PHP. If you need back-end support for Oracle 8,
163 you should install this package in addition to the main %{name}
164 package.
165
166 %description oci8 -l pl
167 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 8. }
168
169 %package oracle
170 Summary:        Oracle 7 database module for PHP
171 Summary(pl):    Modu³ bazy danych Oracle 7 dla PHP
172 Group:          Libraries
173 Group(de):      Libraries
174 Group(fr):      Librairies
175 Group(pl):      Biblioteki
176 PreReq: %{name} = %{version}
177 Autoreq:        false
178
179 %description oracle
180 This is a dynamic shared object (DSO) for Apache that will add Oracle
181 7 database support to PHP. If you need back-end support for Oracle 7,
182 you should install this package in addition to the main %{name}
183 package.
184
185 %description oracle -l pl
186 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 7. }
187
188 %package gd
189 Summary:        GD extension module for PHP
190 Summary:        Modu³ GD dla PHP
191 Group:          Libraries
192 Group(de):      Libraries
193 Group(fr):      Librairies
194 Group(pl):      Biblioteki
195 PreReq: %{name} = %{version}
196
197 %description gd
198 This is a dynamic shared object (DSO) for Apache that will add GD
199 support to PHP. You should install this package in addition to the
200 main %{name} package if you want to create and manipulate images with
201 PHP.
202
203 %description gd -l pl
204
205 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
206 %package java
207 Summary:        Java extension module for PHP
208 Summary(pl):    Modu³ Javy dla PHP
209 Group:          Libraries
210 Group(de):      Libraries
211 Group(fr):      Librairies
212 Group(pl):      Biblioteki
213 PreReq: %{name} = %{version}
214
215 %description java
216 This is a dynamic shared object (DSO) for Apache that will add JAVA
217 support to PHP. This extension provides a simple and effective means
218 for creating and invoking methods on Java objects from PHP.
219
220 %description java -l pl
221 %endif
222
223 %package xml
224 Summary:        XML extension module for PHP
225 Summary(pl):    Modu³ XML dla PHP
226 Group:          Libraries
227 Group(de):      Libraries
228 Group(fr):      Librairies
229 Group(pl):      Biblioteki
230 PreReq: %{name} = %{version}
231
232 %description xml
233 This is a dynamic shared object (DSO) for Apache that will add XML
234 support to PHP. This extension lets you create XML parsers and then
235 define handlers for different XML events. If you want to be able to
236 parse XML documents you should install this package in addition to the
237 main %{name} package.
238
239 #%description xml -l pl
240
241 %package dba
242 Summary:        DBA extension module for PHP
243 Summary(pl):    Modu³ DBA dla PHP
244 Group:          Libraries
245 Group(de):      Libraries
246 Group(fr):      Librairies
247 Group(pl):      Biblioteki
248 PreReq: %{name} = %{version}
249
250 %description dba
251 This is a dynamic shared object (DSO) for Apache that will add
252 flat-file databases (DBA) support to PHP.
253
254 #%description dba -l pl
255
256 %package odbc
257 Summary:        ODBC extension module for PHP
258 Summary(pl):    Modu³ ODBC dla PHP
259 Group:          Libraries
260 Group(de):      Libraries
261 Group(fr):      Librairies
262 Group(pl):      Biblioteki
263 PreReq: %{name} = %{version}
264
265 %description odbc
266 This is a dynamic shared object (DSO) for Apache that will add
267 ODBC support to PHP.
268
269 #%description odbc -l pl
270
271 %package calendar
272 Summary:        Calendar extension module for PHP
273 Summary(pl):    Modu³ funkcji kalendarza dla PHP
274 Group:          Libraries
275 Group(de):      Libraries
276 Group(fr):      Librairies
277 Group(pl):      Biblioteki
278 PreReq: %{name} = %{version}
279
280 %description calendar
281 This is a dynamic shared object (DSO) for Apache that will add
282 calendar support to PHP.
283
284 #%description calendar -l pl
285
286 %package dbase
287 Summary:        DBase extension module for PHP
288 Summary(pl):    Modu³ DBase dla PHP
289 Group:          Libraries
290 Group(de):      Libraries
291 Group(fr):      Librairies
292 Group(pl):      Biblioteki
293 PreReq: %{name} = %{version}
294
295 %description dbase
296 This is a dynamic shared object (DSO) for Apache that will add DBase
297 support to PHP.
298
299 #%description dbase -l pl
300
301 %package filepro
302 Summary:        FilePro extension module for PHP
303 Summary(pl):    Modu³ FilePro dla PHP
304 Group:          Libraries
305 Group(de):      Libraries
306 Group(fr):      Librairies
307 Group(pl):      Biblioteki
308 PreReq: %{name} = %{version}
309
310 %description filepro
311 This is a dynamic shared object (DSO) for Apache that will add FilePro
312 support to PHP.
313
314 #%description filepro -l pl
315
316 %package posix
317 Summary:        POSIX extension module for PHP
318 Summary(pl):    Modu³ POSIX dla PHP
319 Group:          Libraries
320 Group(de):      Libraries
321 Group(fr):      Librairies
322 Group(pl):      Biblioteki
323 PreReq: %{name} = %{version}
324
325 %description posix
326 This is a dynamic shared object (DSO) for Apache that will add POSIX
327 functions support to PHP.
328
329 #%description posix -l pl
330
331 %package pcre
332 Summary:        PCRE extension module for PHP
333 Summary(pl):    Modu³ PCRE dla PHP
334 Group:          Libraries
335 Group(de):      Libraries
336 Group(fr):      Librairies
337 Group(pl):      Biblioteki
338 PreReq: %{name} = %{version}
339
340 %description pcre
341 This is a dynamic shared object (DSO) for Apache that will add Perl
342 Compatible Regular Expression support to PHP.
343
344 #%description pcre -l pl
345
346 %package sysvsem
347 Summary:        SysV sem extension module for PHP
348 Summary(pl):    Modu³ SysV sem dla PHP
349 Group:          Libraries
350 Group(de):      Libraries
351 Group(fr):      Librairies
352 Group(pl):      Biblioteki
353 PreReq: %{name} = %{version}
354
355 %description sysvsem
356 This is a dynamic shared object (DSO) for Apache that will add SysV
357 semafores support to PHP.
358
359 #%description sysvsem -l pl
360
361 %package sysvshm
362 Summary:        SysV shm extension module for PHP
363 Summary(pl):    Modu³ SysV shm dla PHP
364 Group:          Libraries
365 Group(de):      Libraries
366 Group(fr):      Librairies
367 Group(pl):      Biblioteki
368 PreReq: %{name} = %{version}
369
370 %description sysvshm
371 This is a dynamic shared object (DSO) for Apache that will add SysV
372 Shared Memory support to PHP.
373
374 #%description sysvshm -l pl
375
376 %package yp
377 Summary:        NIS (yp) extension module for PHP
378 Summary(pl):    Modu³ NIS (yp) dla PHP
379 Group:          Libraries
380 Group(de):      Libraries
381 Group(fr):      Librairies
382 Group(pl):      Biblioteki
383 PreReq: %{name} = %{version}
384
385 %description yp
386 This is a dynamic shared object (DSO) for Apache that will add NIS
387 (Yellow Pages) support to PHP.
388
389 #%description yp -l pl
390
391 %package bcmath
392 Summary:        bcmath extension module for PHP
393 Summary(pl):    Modu³ bcmath dla PHP
394 Group:          Libraries
395 Group(de):      Libraries
396 Group(fr):      Librairies
397 Group(pl):      Biblioteki
398 PreReq: %{name} = %{version}
399
400 %description bcmath
401 This is a dynamic shared object (DSO) for Apache that will add bc
402 style precision math functions support to PHP.
403
404 #%description bcmath -l pl
405
406 %package ftp
407 Summary:        FTP extension module for PHP
408 Summary(pl):    Modu³ FTP dla PHP
409 Group:          Libraries
410 Group(de):      Libraries
411 Group(fr):      Librairies
412 Group(pl):      Biblioteki
413 PreReq: %{name} = %{version}
414
415 %description ftp
416 This is a dynamic shared object (DSO) for Apache that will add FTP
417 support to PHP.
418
419 #%description ftp -l pl
420
421 %package zlib
422 Summary:        Zlib extension module for PHP
423 Summary(pl):    Modu³ zlib dla PHP
424 Group:          Libraries
425 Group(de):      Libraries
426 Group(fr):      Librairies
427 Group(pl):      Biblioteki
428 PreReq: %{name} = %{version}
429
430 %description zlib
431 This is a dynamic shared object (DSO) for Apache that will add
432 commpresion (zlib) support to PHP.
433
434 #%description zlib -l pl
435
436 %package exif
437 Summary:        exifextension module for PHP
438 Summary(pl):    Modu³ exif dla PHP
439 Group:          Libraries
440 Group(de):      Libraries
441 Group(fr):      Librairies
442 Group(pl):      Biblioteki
443 PreReq: %{name} = %{version}
444
445 %description exif
446 This is a dynamic shared object (DSO) for Apache that will add exif
447 support to PHP.
448
449 #%description exif -l pl
450
451 %package recode
452 Summary:        recodeextension module for PHP
453 Summary(pl):    Modu³ recode dla PHP
454 Group:          Libraries
455 Group(de):      Libraries
456 Group(fr):      Librairies
457 Group(pl):      Biblioteki
458 PreReq: %{name} = %{version}
459
460 %description recode
461 This is a dynamic shared object (DSO) for Apache that will add recode
462 support to PHP.
463
464 #%description recode -l pl
465
466 %package session
467 Summary:        sessionextension module for PHP
468 Summary(pl):    Modu³ session dla PHP
469 Group:          Libraries
470 Group(de):      Libraries
471 Group(fr):      Librairies
472 Group(pl):      Biblioteki
473 PreReq: %{name} = %{version}
474
475 %description session
476 This is a dynamic shared object (DSO) for Apache that will add session
477 support to PHP.
478
479 #%description session -l pl
480
481 %package gettext
482 Summary:        gettextextension module for PHP
483 Summary(pl):    Modu³ gettext dla PHP
484 Group:          Libraries
485 Group(de):      Libraries
486 Group(fr):      Librairies
487 Group(pl):      Biblioteki
488 PreReq: %{name} = %{version}
489
490 %description gettext
491 This is a dynamic shared object (DSO) for Apache that will add gettext
492 support to PHP.
493
494 #%description gettext -l pl
495
496
497 %package snmp
498 Summary:        snmpextension module for PHP
499 Summary(pl):    Modu³ snmp dla PHP
500 Group:          Libraries
501 Group(de):      Libraries
502 Group(fr):      Librairies
503 Group(pl):      Biblioteki
504 PreReq: %{name} = %{version}
505
506 %description snmp
507 This is a dynamic shared object (DSO) for Apache that will add snmp
508 support to PHP.
509
510 #%description snmp -l pl
511
512 %package imap
513 Summary:        imapextension module for PHP
514 Summary(pl):    Modu³ imap dla PHP
515 Group:          Libraries
516 Group(de):      Libraries
517 Group(fr):      Librairies
518 Group(pl):      Biblioteki
519 PreReq: %{name} = %{version}
520
521 %description imap
522 This is a dynamic shared object (DSO) for Apache that will add imap
523 support to PHP.
524
525 #%description imap -l pl
526
527 %package ldap
528 Summary:        LDAP extension module for PHP
529 Summary(pl):    Modu³ LDAP dla PHP
530 Group:          Libraries
531 Group(de):      Libraries
532 Group(fr):      Librairies
533 Group(pl):      Biblioteki
534 PreReq: %{name} = %{version}
535
536 %description ldap
537 This is a dynamic shared object (DSO) for Apache that will add LDAP
538 support to PHP.
539
540 #%description ldap -l pl
541
542 %package sockets
543 Summary:        sockets extension module for PHP
544 Summary(pl):    Modu³ socket dla PHP
545 Group:          Libraries
546 Group(de):      Libraries
547 Group(fr):      Librairies
548 Group(pl):      Biblioteki
549 PreReq: %{name} = %{version}
550
551 %description sockets
552 This is a dynamic shared object (DSO) for Apache that will add sockets
553 support to PHP.
554
555 #%description sockets -l pl
556
557 %package mcrypt
558 Summary:        mcrypt extension module for PHP
559 Summary(pl):    Modu³ mcrypt dla PHP
560 Group:          Libraries
561 Group(de):      Libraries
562 Group(fr):      Librairies
563 Group(pl):      Biblioteki
564 PreReq: %{name} = %{version}
565
566 %description mcrypt
567 This is a dynamic shared object (DSO) for Apache that will add mcrypt
568 support to PHP.
569
570 #%description mcrypt -l pl
571
572 %package mhash
573 Summary:        mhash extension module for PHP
574 Summary(pl):    Modu³ mhash dla PHP
575 Group:          Libraries
576 Group(de):      Libraries
577 Group(fr):      Librairies
578 Group(pl):      Biblioteki
579 PreReq: %{name} = %{version}
580
581 %description mhash
582 This is a dynamic shared object (DSO) for Apache that will add mhash
583 support to PHP.
584
585 #%description mcrypt -l pl
586
587
588 %package doc
589 Summary:        Online manual for PHP
590 Summary(pl):    Dokumentacja dla PHP
591 Group:          Networking/Daemons
592 Group(de):      Netzwerkwesen/Server
593 Group(pl):      Sieciowe/Serwery
594
595 %description doc
596 Comprehensive documentation for PHP, viewable through your web
597 server, too!
598
599 %description doc -l pl
600 Dokumentacja dla pakietu PHP. Mo¿na j± równie¿ ogl±daæ poprzez serwer
601 WWW.
602
603 %package pear
604 Summary:        PEAR
605 Group:          Development/Languages/PHP
606
607 %description pear
608 PEAR.
609
610 %package devel
611 Summary:        Files for PHP modules development
612 Group:          Development/Languages/PHP
613
614 %description devel
615 Files for PHP modules development.
616
617 %prep
618 %setup  -q
619 %patch0 -p1
620 %patch1 -p1
621 %patch2 -p1
622 %patch5 -p1
623 %patch6 -p1
624 %patch7 -p1
625 %patch8 -p1
626 #%patch9 -p1
627
628
629 %build
630 CFLAGS="$RPM_OPT_FLAGS -DEAPI -I/usr/X11R6/include"; export CFLAGS
631 ./buildconf
632 %configure \
633         --with-apxs=/usr/sbin/apxs \
634         --with-config-file-path=%{_sysconfdir}/apache \
635         --with-exec-dir=%{_bindir} \
636         --disable-debug \
637         --enable-magic-quotes \
638         --enable-shared \
639         --enable-track-vars \
640         --enable-safe-mode \
641         --enable-trans-sid \
642         --enable-sysvsem=shared \
643         --enable-sysvshm=shared \
644         --enable-shmop=shared \
645         --enable-session \
646         --enable-exif=shared \
647         --with-regex=system \
648         --with-gettext=shared \
649         %{!?bcond_off_ldap:--with-ldap=shared} \
650         --with-mysql=shared \
651         --with-mysql-sock=/var/lib/mysql/mysql.sock \
652         --with-gd=shared \
653          --enable-gd-imgstrttf \
654         --with-dbase=shared \
655         --with-filepro=shared \
656         --enable-ftp=shared \
657         --with-hyperwave \
658         --with-pdflib=shared \
659         --with-cpdflib=shared \
660         %{?bcond_on_java:--with-java} \
661         --with-pgsql=shared,/usr \
662         --with-imap=shared \
663         --enable-bcmath=shared \
664         --enable-calendar=shared \
665         --with-mm \
666         --with-pcre-regex=shared \
667         --enable-posix=shared \
668         --with-ttf \
669         --with-t1lib \
670         --with-recode=shared \
671         --enable-ucd-snmp-hack \
672         --enable-dba=shared \
673         --with-snmp=shared \
674         --with-openssl \
675         --with-gdbm \
676         --with-db3 \
677         --enable-yp=shared \
678         --with-xml=shared \
679         --enable-xml=shared \
680         --with-zlib=shared \
681         --with-mcrypt=shared \
682         --enable-sockets=shared \
683         --with-bz2=shared \
684         --with-ctype=shared \
685         --with-mhash=shared \
686         --with-curl=shared \
687         --with-gmp=shared \
688         %{?bcond_on_openssl:--with-openssl} \
689         --with-unixODBC=shared \
690         %{?bcond_on_oracle:--with-oracle=shared} \
691         %{?bcond_on_oci8:--with-oci8=shared} \
692         --without-db2 
693
694
695
696 # TODO --with-pspell=/usr,shared (pspell missing)
697
698
699 # --with-dom need libxml >= 2.2.7 \
700
701 %{__make}
702
703 %install
704 rm -rf $RPM_BUILD_ROOT
705 install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache},%{_sysconfdir}/{apache,cgi}} \
706                 $RPM_BUILD_ROOT/home/httpd/html/{icons,docs,docs/php4-doc} \
707                 $RPM_BUILD_ROOT/%{_sbindir}
708
709 %{__make} install DESTDIR=$RPM_BUILD_ROOT INSTALL_IT="install .libs/*.so $RPM_BUILD_ROOT%{_libdir}/apache/"
710 #exit 1
711 #install .libs/*.so     $RPM_BUILD_ROOT%{_pkglibdir}
712 #install modules/*.so   $RPM_BUILD_ROOT%{_pkglibdir}/php
713
714 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/apache/php.ini
715 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
716 install %{SOURCE5} $RPM_BUILD_ROOT/%{_sbindir}
717
718 tar zxf %{SOURCE4} -C $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc
719 ln -s manual.html $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc/index.html
720
721 install %{SOURCE1} .
722 gzip -9nf CODING_STANDARDS CREDITS FUNCTION_LIST.txt \
723       EXTENSIONS NEWS TODO* LICENSE Zend/LICENSE \
724       Zend/ZEND_CHANGES README.SELF-CONTAINED-EXTENSIONS README.EXT_SKEL
725
726 %post
727 /usr/sbin/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
728 perl -pi -e 's|^#AddType application/x-httpd-php .php|AddType application/x-httpd-php .php|'
729 if [ -f /var/lock/subsys/httpd ]; then
730         /etc/rc.d/init.d/httpd restart 1>&2
731 fi
732
733 %postun
734 perl -pi -e 's|^AddType application/x-httpd-php .php|#AddType application/x-httpd-php .php|'
735 if [ -f /var/lock/subsys/httpd ]; then
736       /etc/rc.d/init.d/httpd restart 1>&2
737 fi
738
739 %preun
740 if [ "$1" = "0" ]; then
741         /usr/sbin/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
742         if [ -f /var/lock/subsys/httpd ]; then
743                 /etc/rc.d/init.d/httpd restart 1>&2
744         fi
745 fi
746
747
748 %post bcmath
749 %{_sbindir}/php-module-install install bcmath %{_sysconfdir}/apache/php.ini
750
751 %preun bcmath
752 if [ "$1" = "0" ]; then
753         %{_sbindir}/php-module-install remove bcmath %{_sysconfdir}/apache/php.ini
754 fi
755
756 %post calendar
757 %{_sbindir}/php-module-install install calendar %{_sysconfdir}/apache/php.ini
758
759 %preun calendar
760 if [ "$1" = "0" ]; then
761         %{_sbindir}/php-module-install remove calendar %{_sysconfdir}/apache/php.ini
762 fi
763
764 %post dba
765 %{_sbindir}/php-module-install install dba %{_sysconfdir}/apache/php.ini
766
767 %preun dba
768 if [ "$1" = "0" ]; then
769         %{_sbindir}/php-module-install remove dba %{_sysconfdir}/apache/php.ini
770 fi
771
772 %post dbase
773 %{_sbindir}/php-module-install install dbase %{_sysconfdir}/apache/php.ini
774
775 %preun dbase
776 if [ "$1" = "0" ]; then
777         %{_sbindir}/php-module-install remove dbase %{_sysconfdir}/apache/php.ini
778 fi
779
780 %post exif
781 %{_sbindir}/php-module-install install exif %{_sysconfdir}/apache/php.ini
782
783 %preun exif
784 if [ "$1" = "0" ]; then
785         %{_sbindir}/php-module-install remove exif %{_sysconfdir}/apache/php.ini
786 fi
787
788 %post filepro
789 %{_sbindir}/php-module-install install filepro %{_sysconfdir}/apache/php.ini
790
791 %preun filepro
792 if [ "$1" = "0" ]; then
793         %{_sbindir}/php-module-install remove filepro %{_sysconfdir}/apache/php.ini
794 fi
795
796 %post ftp
797 %{_sbindir}/php-module-install install ftp %{_sysconfdir}/apache/php.ini
798
799 %preun ftp
800 if [ "$1" = "0" ]; then
801         %{_sbindir}/php-module-install remove ftp %{_sysconfdir}/apache/php.ini
802 fi
803
804 %post gd
805 %{_sbindir}/php-module-install install gd %{_sysconfdir}/apache/php.ini
806
807 %preun gd
808 if [ "$1" = "0" ]; then
809         %{_sbindir}/php-module-install remove gd %{_sysconfdir}/apache/php.ini
810 fi
811
812 %post gettext
813 %{_sbindir}/php-module-install install gettext %{_sysconfdir}/apache/php.ini
814
815 %preun gettext
816 if [ "$1" = "0" ]; then
817         %{_sbindir}/php-module-install remove gettext %{_sysconfdir}/apache/php.ini
818 fi
819
820 %post imap
821 %{_sbindir}/php-module-install install imap %{_sysconfdir}/apache/php.ini
822
823 %preun imap
824 if [ "$1" = "0" ]; then
825         %{_sbindir}/php-module-install remove imap %{_sysconfdir}/apache/php.ini
826 fi
827
828 %if %{?bond_on_java:1}%{!?bond_on_java:0}
829 %post java
830 %{_sbindir}/php-module-install install libphp_java %{_sysconfdir}/apache/php.ini
831
832 %preun java
833 if [ "$1" = "0" ]; then
834         %{_sbindir}/php-module-install remove libphp_java %{_sysconfdir}/apache/php.ini
835 fi
836 %endif
837
838 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
839 %post ldap
840 %{_sbindir}/php-module-install install ldap %{_sysconfdir}/apache/php.ini
841
842 %preun ldap
843 if [ "$1" = "0" ]; then
844         %{_sbindir}/php-module-install remove ldap %{_sysconfdir}/apache/php.ini
845 fi
846 %endif
847
848 %post mcrypt
849 %{_sbindir}/php-module-install install mcrypt %{_sysconfdir}/apache/php.ini
850
851 %preun mcrypt
852 if [ "$1" = "0" ]; then
853         %{_sbindir}/php-module-install remove mcrypt %{_sysconfdir}/apache/php.ini
854 fi
855
856 %post mhash
857 %{_sbindir}/php-module-install install mhash %{_sysconfdir}/apache/php.ini
858
859 %preun mhash
860 if [ "$1" = "0" ]; then
861         %{_sbindir}/php-module-install remove mhash %{_sysconfdir}/apache/php.ini
862 fi
863
864 %post mysql
865 %{_sbindir}/php-module-install install mysql %{_sysconfdir}/apache/php.ini
866
867 %preun mysql
868 if [ "$1" = "0" ]; then
869         %{_sbindir}/php-module-install remove mysql %{_sysconfdir}/apache/php.ini
870 fi
871
872 %if %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
873 %post oci8
874 %{_sbindir}/php-module-install install oci8 %{_sysconfdir}/apache/php.ini
875
876 %preun oci8
877 if [ "$1" = "0" ]; then
878         %{_sbindir}/php-module-install remove oci8 %{_sysconfdir}/apache/php.ini
879 fi
880 %endif
881
882 %post odbc
883 %{_sbindir}/php-module-install install odbc %{_sysconfdir}/apache/php.ini
884
885 %preun odbc
886 if [ "$1" = "0" ]; then
887         %{_sbindir}/php-module-install remove odbc %{_sysconfdir}/apache/php.ini
888 fi
889
890 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
891 %post oracle
892 %{_sbindir}/php-module-install install oracle %{_sysconfdir}/apache/php.ini
893
894 %preun oracle
895 if [ "$1" = "0" ]; then
896         %{_sbindir}/php-module-install remove oracle %{_sysconfdir}/apache/php.ini
897 fi
898 %endif
899
900 %post pcre
901 %{_sbindir}/php-module-install install pcre %{_sysconfdir}/apache/php.ini
902
903 %preun pcre
904 if [ "$1" = "0" ]; then
905         %{_sbindir}/php-module-install remove pcre %{_sysconfdir}/apache/php.ini
906 fi
907
908 %post pgsql
909 %{_sbindir}/php-module-install install pgsql %{_sysconfdir}/apache/php.ini
910
911 %preun pgsql
912 if [ "$1" = "0" ]; then
913         %{_sbindir}/php-module-install remove pgsql %{_sysconfdir}/apache/php.ini
914 fi
915
916 %post posix
917 %{_sbindir}/php-module-install install posix %{_sysconfdir}/apache/php.ini
918
919 %preun posix
920 if [ "$1" = "0" ]; then
921         %{_sbindir}/php-module-install remove posix %{_sysconfdir}/apache/php.ini
922 fi
923
924 %post recode
925 %{_sbindir}/php-module-install install recode %{_sysconfdir}/apache/php.ini
926
927 %preun recode
928 if [ "$1" = "0" ]; then
929         %{_sbindir}/php-module-install remove recode %{_sysconfdir}/apache/php.ini
930 fi
931
932 %post session
933 %{_sbindir}/php-module-install install session %{_sysconfdir}/apache/php.ini
934
935 %preun session
936 if [ "$1" = "0" ]; then
937         %{_sbindir}/php-module-install remove session %{_sysconfdir}/apache/php.ini
938 fi
939
940 %post snmp
941 %{_sbindir}/php-module-install install snmp %{_sysconfdir}/apache/php.ini
942
943 %preun snmp
944 if [ "$1" = "0" ]; then
945         %{_sbindir}/php-module-install remove snmp %{_sysconfdir}/apache/php.ini
946 fi
947
948 %post sockets
949 %{_sbindir}/php-module-install install sockets %{_sysconfdir}/apache/php.ini
950
951 %preun sockets
952 if [ "$1" = "0" ]; then
953         %{_sbindir}/php-module-install remove sockets %{_sysconfdir}/apache/php.ini
954 fi
955
956 %post sysvsem
957 %{_sbindir}/php-module-install install sysvsem %{_sysconfdir}/apache/php.ini
958
959 %preun sysvsem
960 if [ "$1" = "0" ]; then
961         %{_sbindir}/php-module-install remove sysvsem %{_sysconfdir}/apache/php.ini
962 fi
963
964 %post sysvshm
965 %{_sbindir}/php-module-install install sysvshm %{_sysconfdir}/apache/php.ini
966
967 %preun sysvshm
968 if [ "$1" = "0" ]; then
969         %{_sbindir}/php-module-install remove sysvshm %{_sysconfdir}/apache/php.ini
970 fi
971
972 %post xml
973 %{_sbindir}/php-module-install install xml %{_sysconfdir}/apache/php.ini
974
975 %preun xml
976 if [ "$1" = "0" ]; then
977         %{_sbindir}/php-module-install remove xml %{_sysconfdir}/apache/php.ini
978 fi
979
980 %post yp
981 %{_sbindir}/php-module-install install yp %{_sysconfdir}/apache/php.ini
982
983 %preun yp
984 if [ "$1" = "0" ]; then
985         %{_sbindir}/php-module-install remove yp %{_sysconfdir}/apache/php.ini
986 fi
987
988 %post zlib
989 %{_sbindir}/php-module-install install zlib %{_sysconfdir}/apache/php.ini
990
991 %preun zlib
992 if [ "$1" = "0" ]; then
993         %{_sbindir}/php-module-install remove zlib %{_sysconfdir}/apache/php.ini
994 fi
995
996 %clean
997 rm -rf $RPM_BUILD_ROOT
998
999 %files
1000 %defattr(644,root,root,755)
1001 %doc {CODING_STANDARDS,CREDITS,FUNCTION_LIST.txt,Zend/ZEND_CHANGES}.gz
1002 %doc {LICENSE,Zend/LICENSE,EXTENSIONS,NEWS,TODO*}.gz  
1003 %doc {README.EXT_SKEL,README.SELF-CONTAINED-EXTENSIONS}.gz
1004
1005 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/apache/*
1006
1007
1008 /home/httpd/html/icons/*
1009
1010 %attr(755,root,root) %{_libdir}/apache/libphp4.so
1011 %attr(755,root,root) %{_sbindir}/*
1012
1013 %dir %{_libdir}/php
1014 %dir %{_libdir}/php/extensions
1015 %dir %{extensionsdir}
1016
1017 %files devel
1018 %defattr(644,root,root,755)
1019 %{_includedir}/php4
1020 %{_libdir}/php4/build
1021 %attr(755,root,root) %{_bindir}/phpextdist
1022 %attr(755,root,root) %{_bindir}/phpize
1023 %attr(755,root,root) %{_bindir}/php-config
1024
1025 %files pear
1026 %defattr(644,root,root,755)
1027 %attr(755,root,root) %{_bindir}/pear
1028 %{_libdir}/php/Benchmark
1029 %{_libdir}/php/Crypt
1030 %{_libdir}/php/Date
1031 %{_libdir}/php/DB
1032 %{_libdir}/php/File
1033 %{_libdir}/php/HTML
1034 %{_libdir}/php/Mail
1035 %{_libdir}/php/Math
1036 %{_libdir}/php/Net
1037 %{_libdir}/php/Payment
1038 %{_libdir}/php/PEAR
1039 %{_libdir}/php/XML
1040 %{_libdir}/php/*.php
1041
1042
1043 %files mysql
1044 %defattr(644,root,root,755)
1045 %attr(755,root,root) %{extensionsdir}/mysql.*
1046
1047 %files pgsql
1048 %defattr(644,root,root,755)
1049 %attr(755,root,root) %{extensionsdir}/pgsql.so
1050
1051 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
1052 %files oracle
1053 %defattr(644,root,root,755)
1054 %attr(755,root,root) %{extensionsdir}/oracle.so
1055 %endif
1056
1057 %if  %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
1058 %files oci8
1059 %defattr(644,root,root,755)
1060 %attr(755,root,root) %{extensionsdir}/oci8.so
1061 %endif
1062
1063 %files gd
1064 %defattr(644,root,root,755)
1065 %attr(755,root,root) %{extensionsdir}/gd.so
1066
1067 %files xml
1068 %defattr(644,root,root,755)
1069 %attr(755,root,root) %{extensionsdir}/xml.so
1070
1071 %files dba
1072 %defattr(644,root,root,755)
1073 %attr(755,root,root) %{extensionsdir}/dba.so
1074
1075 %files dbase
1076 %defattr(644,root,root,755)
1077 %attr(755,root,root) %{extensionsdir}/dbase.so
1078
1079 %files filepro
1080 %defattr(644,root,root,755)
1081 %attr(755,root,root) %{extensionsdir}/filepro.so
1082
1083 %files pcre
1084 %defattr(644,root,root,755)
1085 %attr(755,root,root) %{extensionsdir}/pcre.so
1086
1087 %files posix
1088 %defattr(644,root,root,755)
1089 %attr(755,root,root) %{extensionsdir}/posix.so
1090
1091 %files sysvsem
1092 %defattr(644,root,root,755)
1093 %attr(755,root,root) %{extensionsdir}/sysvsem.so
1094
1095 %files sysvshm
1096 %defattr(644,root,root,755)
1097 %attr(755,root,root) %{extensionsdir}/sysvshm.so
1098
1099 %files yp
1100 %defattr(644,root,root,755)
1101 %attr(755,root,root) %{extensionsdir}/yp.so
1102
1103 %files calendar
1104 %defattr(644,root,root,755)
1105 %attr(755,root,root) %{extensionsdir}/calendar.so
1106
1107 %files bcmath
1108 %defattr(644,root,root,755)
1109 %attr(755,root,root) %{extensionsdir}/bcmath.so
1110
1111 %files ftp
1112 %defattr(644,root,root,755)
1113 %attr(755,root,root) %{extensionsdir}/ftp.so
1114
1115 %files zlib
1116 %defattr(644,root,root,755)
1117 %attr(755,root,root) %{extensionsdir}/zlib.so
1118
1119 %files exif
1120 %defattr(644,root,root,755)
1121 %attr(755,root,root) %{extensionsdir}/exif.so
1122
1123 %files recode
1124 %defattr(644,root,root,755)
1125 %attr(755,root,root) %{extensionsdir}/recode.so
1126
1127 #%files session
1128 #%defattr(644,root,root,755)
1129 #%attr(755,root,root) %{extensionsdir}/session.so
1130
1131 %files gettext
1132 %defattr(644,root,root,755)
1133 %attr(755,root,root) %{extensionsdir}/gettext.so
1134
1135 %files imap
1136 %defattr(644,root,root,755)
1137 %attr(755,root,root) %{extensionsdir}/imap.so
1138
1139 %files snmp
1140 %defattr(644,root,root,755)
1141 %attr(755,root,root) %{extensionsdir}/snmp.so
1142
1143 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
1144 %files java
1145 %defattr(644,root,root,755)
1146 %attr(755,root,root) %{extensionsdir}/libphp_java.so
1147 %endif
1148
1149 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
1150 %files ldap
1151 %defattr(644,root,root,755)
1152 %attr(755,root,root) %{extensionsdir}/ldap.*
1153 %endif
1154
1155 %files sockets
1156 %defattr(644,root,root,755)
1157 %attr(755,root,root) %{extensionsdir}/sockets.so
1158
1159 %files mcrypt
1160 %defattr(644,root,root,755)
1161 %attr(755,root,root) %{extensionsdir}/mcrypt.so
1162
1163 %files mhash
1164 %defattr(644,root,root,755)
1165 %attr(755,root,root) %{extensionsdir}/mhash.so
1166
1167 %files odbc
1168 %defattr(644,root,root,755)
1169 %attr(755,root,root) %{extensionsdir}/odbc.so
1170
1171 %files doc
1172 %defattr(644,root,root,755)
1173 /home/httpd/html/docs/php4-doc
This page took 0.1732 seconds and 3 git commands to generate.