]> git.pld-linux.org Git - SPECS.git/blob - php-wbxml.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / php-wbxml.spec
1 %define         _modname        wbxml
2 Summary:        PHP WBXML Library wrapper
3 Summary(pl.UTF-8):      Wrapper PHP do biblioteki WBXML
4 Name:           php-wbxml
5 Version:        0.1
6 Release:        0.2
7 License:        PHP 2.02
8 Group:          Libraries
9 Source0:        http://www.k-fish.de/fileadmin/wbxml-%{version}.tar.gz
10 # Source0-md5:  73c23a4848478715254be2dc104596ec
11 URL:            http://www.k-fish.de/SyncML_support.57.0.html
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  php-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 BuildRequires:  libwbxml-devel
17 %{?requires_php_extension}
18 Requires:       php-common >= 4:5.0.4
19 Requires:       libwbxml
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is a simple extension that acts as a wrapper around the
24 conversion functions in the WBXML Library written by Aymerick Jehanne.
25
26 %description -l en.UTF-8
27 This is a simple extension that acts as a wrapper around the
28 conversion functions in the WBXML Library written by Aymerick Jéhanne.
29
30 %description -l pl.UTF-8
31 To jest proste rozszerzenie obudowujące funkcje konwersji z biblioteki
32 WBXML napisanej przez Aymericka Jéhanne'a.
33
34 %prep
35 %setup -q -n wbxml-%{version}
36
37 %build
38 phpize
39 %{__aclocal}
40 %{__autoconf}
41 %{__autoheader}
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
48
49 %{__make} install \
50         INSTALL_ROOT=$RPM_BUILD_ROOT
51
52 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
53 ; Enable %{_modname} extension module
54 extension=%{_modname}.so
55 EOF
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %php_webserver_restart
62
63 %postun
64 if [ "$1" = 0 ]; then
65         %php_webserver_restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README CREDITS
71 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
72 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.29583 seconds and 3 git commands to generate.