]> git.pld-linux.org Git - SPECS.git/blob - php-symfony2-Security.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / php-symfony2-Security.spec
1 %define         package Security
2 %define         php_min_version 5.3.9
3 Summary:        Symfony2 Security Component
4 Name:           php-symfony2-Security
5 Version:        2.8.52
6 Release:        1
7 License:        MIT
8 Group:          Development/Languages/PHP
9 Source0:        https://github.com/symfony/%{package}/archive/v%{version}/%{package}-%{version}.tar.gz
10 # Source0-md5:  1fbd8e2addcead868966b0bd0ae9bc55
11 URL:            http://symfony.com/doc/2.7/book/security.html
12 BuildRequires:  phpab
13 BuildRequires:  rpmbuild(macros) >= 1.610
14 Requires:       php(core) >= %{php_min_version}
15 Requires:       php(date)
16 Requires:       php(hash)
17 Requires:       php(json)
18 Requires:       php(pcre)
19 Requires:       php(session)
20 Requires:       php(spl)
21 Requires:       php-dirs >= 1.6
22 Requires:       php-symfony2-EventDispatcher >= 2.2
23 Requires:       php-symfony2-HttpFoundation >= 2.1
24 Requires:       php-symfony2-HttpKernel >= 2.1
25 Suggests:       php-symfony2-ClassLoader
26 Suggests:       php-symfony2-Finder
27 Suggests:       php-symfony2-Form
28 Suggests:       php-symfony2-Routing
29 Suggests:       php-symfony2-Validator
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Provides an infrastructure for sophisticated authorization systems.
35
36 %prep
37 %setup -q -n security-%{version}
38
39 rm */.gitignore
40 rm */composer.json
41 rm */phpunit.xml.dist
42 for c in Core Guard Http; do
43         mv $c/LICENSE LICENSE_$c
44         mv $c/README.md README_$c.md
45 done
46
47 %build
48 phpab -n -e '*/Tests/*' -o autoload.php .
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}
53 cp -a *.php */ $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}
54 rm -r $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}/Core/Tests
55 rm -r $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}/Csrf/Tests
56 rm -r $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}/Guard/Tests
57 rm -r $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}/Http/Tests
58 rm -r $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}/Tests
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CHANGELOG.md README*.md LICENSE*
66 %dir %{php_data_dir}/Symfony/Component/Security
67 %{php_data_dir}/Symfony/Component/Security/*.php
68 %{php_data_dir}/Symfony/Component/Security/Core
69 %{php_data_dir}/Symfony/Component/Security/Csrf
70 %{php_data_dir}/Symfony/Component/Security/Guard
71 %{php_data_dir}/Symfony/Component/Security/Http
72
73 %dir %{php_data_dir}/Symfony/Component/Security/Resources
74 %dir %{php_data_dir}/Symfony/Component/Security/Resources/translations
75 %lang(ar) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.ar.xlf
76 %lang(az) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.az.xlf
77 %lang(bg) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.bg.xlf
78 %lang(ca) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.ca.xlf
79 %lang(cs) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.cs.xlf
80 %lang(da) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.da.xlf
81 %lang(de) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.de.xlf
82 %lang(el) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.el.xlf
83 %lang(en) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.en.xlf
84 %lang(es) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.es.xlf
85 %lang(fa) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.fa.xlf
86 %lang(fr) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.fr.xlf
87 %lang(gl) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.gl.xlf
88 %lang(he) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.he.xlf
89 %lang(hr) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.hr.xlf
90 %lang(hu) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.hu.xlf
91 %lang(id) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.id.xlf
92 %lang(it) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.it.xlf
93 %lang(ja) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.ja.xlf
94 %lang(lb) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.lb.xlf
95 %lang(lt) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.lt.xlf
96 %lang(lv) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.lv.xlf
97 %lang(nb) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.nb.xlf
98 %lang(nl) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.nl.xlf
99 %lang(nn) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.nn.xlf
100 %lang(no) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.no.xlf
101 %lang(pl) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.pl.xlf
102 %lang(pt_BR) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.pt_BR.xlf
103 %lang(pt_PT) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.pt_PT.xlf
104 %lang(ro) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.ro.xlf
105 %lang(ru) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.ru.xlf
106 %lang(sk) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.sk.xlf
107 %lang(sl) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.sl.xlf
108 %lang(sr@cyrillic) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.sr_Cyrl.xlf
109 %lang(sr@latin) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.sr_Latn.xlf
110 %lang(sv) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.sv.xlf
111 %lang(th) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.th.xlf
112 %lang(tl) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.tl.xlf
113 %lang(tr) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.tr.xlf
114 %lang(ua) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.ua.xlf
115 %lang(vi) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.vi.xlf
116 %lang(zh_CN) %{php_data_dir}/Symfony/Component/Security/Resources/translations/security.zh_CN.xlf
This page took 0.423609 seconds and 3 git commands to generate.