]> git.pld-linux.org Git - projects/template-specs.git/blob - php-pecl.spec
- more specific URL
[projects/template-specs.git] / php-pecl.spec
1 %define         _modname        -
2 %define         _status         -
3 Summary:        %{_modname} -
4 Summary(pl):    %{_modname} -
5 Name:           php-pecl-%{_modname}
6 Version:        1.0
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
11 URL:            http://pear.php.net/package/%{_pearname}/
12 BuildRequires:  libtool
13 BuildRequires:  php-devel
14 Requires:       php-common
15 Obsoletes:      php-pear-%{_modname}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sysconfdir     /etc/php
19 %define         extensionsdir   %{_libdir}/php
20
21 %description
22
23 This extension has in PEAR status: %{_status}.
24
25 %description -l pl
26
27 To rozszerzenie ma w PEAR status: %{_status}.
28
29 %prep
30 %setup -q -c
31
32 %build
33 cd %{_modname}-%{version}
34 phpize
35 %configure
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{extensionsdir}
41
42 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
49
50 %preun
51 if [ "$1" = "0" ]; then
52         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
53 fi
54
55 %files
56 %defattr(644,root,root,755)
57 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.035963 seconds and 4 git commands to generate.