]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-scream.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / php-pecl-scream.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         scream
3 %define         status          alpha
4 Summary:        break the silence operator
5 Summary(pl.UTF-8):      przełamanie operatora wyciszania
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.1.0
8 Release:        9
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  ec606b6b9f23bd7de532c7f77c953852
13 Source1:        %{modname}.ini
14 URL:            https://pecl.php.net/package/scream/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.4
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Provides:       php(%{modname}) = %{version}
19 Obsoletes:      php-pecl-scream < 0.1.0-7
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Allows you to disable the silence operator (@) to get all error
24 messages.
25
26 In PECL status of this extension is: %{status}.
27
28 %description -l pl.UTF-8
29 Rozszerzenie to pozwala na wyłączenie operatora wyciszania (@) w celu
30 uzyskania pełnych komunikatów błędu.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__make} install \
46         INSTALL_ROOT=$RPM_BUILD_ROOT \
47         EXTENSION_DIR=%{php_extensiondir}
48
49 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
50 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
66 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.171232 seconds and 3 git commands to generate.