]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-html_parse.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / php-pecl-html_parse.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         html_parse
3 %define         status          stable
4 Summary:        %{modname} - HTML parser extension
5 Summary(pl.UTF-8):      %{modname} - parser HTML
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.0
8 Release:        5
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  d19772cb926d775313af0fda207e2a90
13 URL:            http://pecl.php.net/package/html_parse/
14 BuildRequires:  %{php_name}-devel >= 4:5.0.4
15 BuildRequires:  ekhtml-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Provides:       php(%{modname}) = %{version}
19 Obsoletes:      php-pear-%{modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 HTML parser extension based on the ekhtml library
24 <http://ekhtml.sourceforge.net/>.
25
26 In PECL status of this package is: %{status}.
27
28 %description -l pl.UTF-8
29 Parser HTML bazowany na bibliotece ekhtml
30 <http://ekhtml.sourceforge.net/>.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46
47 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
49 ; Enable %{modname} extension module
50 extension=%{modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.095337 seconds and 3 git commands to generate.