]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-funcall.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / php-pecl-funcall.spec
1 %define         php_name        php%{?php_suffix}
2 %define         subver  alpha
3 %define         rel             5
4 %define         modname funcall
5 %define         status  stable
6 Summary:        %{modname} - Add callbacks for any function/method
7 Summary(pl.UTF-8):      %{modname} - odwołania dla dowolnej funkcji / metody
8 Name:           %{php_name}-pecl-%{modname}
9 Version:        0.3.0
10 Release:        0.%{subver}.%{rel}
11 License:        New BSD
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{modname}-%{version}%{subver}.tgz
14 # Source0-md5:  65ddff0346ed4ed4fb0e3734ccf1b7d2
15 URL:            http://pecl.php.net/package/funcall/
16 BuildRequires:  %{php_name}-devel >= 4:5.0.4
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Provides:       php(%{modname}) = %{version}
20 Obsoletes:      php-pecl-funcall < 0.3.0-0.alpha.3
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Call callbacks before or after specified functions/methods being
25 called.
26
27 In PECL status of this extension is: %{status}.
28
29 %description -l pl.UTF-8
30 Rozszerzenie to pozwala na wykonywanie odwołań przed lub po wywołaniu
31 określonej funkcji / metody.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}%{?subver}/* .
38
39 %build
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
47
48 %{__make} install \
49         EXTENSION_DIR=%{php_extensiondir} \
50         INSTALL_ROOT=$RPM_BUILD_ROOT
51 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
52 ; Enable %{modname} extension module
53 extension=%{modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc TODO funcall.php
70 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
71 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 3.39723 seconds and 3 git commands to generate.