]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-fam.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / php-pecl-fam.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname fam
3 %define         status          beta
4 Summary:        %{modname} - File Alteration Monitor Functions
5 Summary(pl.UTF-8):      %{modname} - monitor zmian w plikach
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        5.0.1
8 Release:        5
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  2a5e358e7fec4f3b21610423a2652934
13 URL:            http://pecl.php.net/package/fam/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  fam-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 Obsoletes:      php-fam
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 FAM monitors files and directories, notifying interested applications
25 of changes. A PHP script may specify a list of files for FAM to
26 monitor using the functions provided by this extension. The FAM
27 process is started when the first connection from any application to
28 it is opened. It exits after all connections to it have been closed.
29
30 In PECL status of this extension is: %{status}.
31
32 %description -l pl.UTF-8
33 FAM monitoruje pliki i katalogi, informując aplikacje o występujących
34 w nich zmianach. Z poziomu skryptu PHP możliwe jest określenie listy
35 plików jakie FAM ma monitorować. Proces FAM jest uruchomiony gdy
36 pojawi się pierwsze połączenie, a kończony w momencie odłaczenia się
37 ostatniej aplikacji.
38
39 To rozszerzenie ma w PECL status: %{status}.
40
41 %prep
42 %setup -qc
43 mv %{modname}-%{version}/* .
44
45 %build
46 phpize
47 %configure
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
53 %{__make} install \
54         INSTALL_ROOT=$RPM_BUILD_ROOT \
55         EXTENSION_DIR=%{php_extensiondir}
56 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
57 ; Enable %{modname} extension module
58 extension=%{modname}.so
59 EOF
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %php_webserver_restart
66
67 %postun
68 if [ "$1" = 0 ]; then
69         %php_webserver_restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
75 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.640685 seconds and 3 git commands to generate.