]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-cvsclient.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / php-pecl-cvsclient.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname cvsclient
3 %define         status          beta
4 Summary:        %{modname} - CVS pserver client
5 Summary(pl.UTF-8):      %{modname} - klient CVS pserver
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.2
8 Release:        8
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  d25ca6d7797118edf37817fcb7e93bc7
13 URL:            http://pecl.php.net/package/cvsclient/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Obsoletes:      php-pear-%{modname}
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 pserver client extension. Current version has read-only streams
24 wrapper. Later versions to include commit/diff/log support.
25
26 In PECL status of this package is: %{status}.
27
28 %description -l pl.UTF-8
29 Moduł klienta CVS pserver. Na chwilę obecną dostępne jest wsparcie
30 tylko 'read only'. W następnych wersjach planowane jest wsparcie dla
31 komend commit/diff/log.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38
39 %build
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
47
48 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 extension=%{modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %php_webserver_restart
59
60 %postun
61 if [ "$1" = 0 ]; then
62         %php_webserver_restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.529327 seconds and 3 git commands to generate.