]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-apd.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / php-pecl-apd.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname apd
3 %define         status  stable
4 Summary:        %{modname} - full-featured engine-level profiler/debugger
5 Summary(pl.UTF-8):      %{modname} - w pełni funkcjonalny profiler/debugger dla PHP
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.1
8 Release:        9
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  470ea75cde09f7504c83441911c86f29
13 Patch0:         php-pecl-%{modname}-cvs.patch
14 URL:            http://pecl.php.net/package/apd/
15 BuildRequires:  %{php_name}-devel >= 4:5.2.17-8
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_zend_extension}
18 Provides:       php(%{modname}) = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 APD is a full-featured profiler/debugger that is loaded as a
23 zend_extension. It aims to be an analog of C's gprof or Perl's
24 Devel::DProf.
25
26 In PECL status of this package is: %{status}.
27
28 %description -l pl.UTF-8
29 APD to w pełni funkcjonalny profiler/debugger ładowany jako
30 rozszerzenie Zend. Ma być odpowiednikiem gprof z C lub perlowego
31 Devel::DProf.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38 %patch0 -p1
39
40 %build
41 phpize
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
48 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 zend_extension=%{modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %php_webserver_restart
59
60 %postun
61 if [ "$1" = 0 ]; then
62         %php_webserver_restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
69 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.240221 seconds and 3 git commands to generate.