]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-Net_Gopher.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / php-pecl-Net_Gopher.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname Net_Gopher
3 %define         extname gopher
4 %define         status  stable
5 Summary:        %{modname} - fopen wrapper for the gopher protocol
6 Summary(pl.UTF-8):      %{modname} - wrapper fopen dla protokołu gopher
7 Name:           %{php_name}-pecl-%{modname}
8 Version:        1.0.0
9 Release:        8
10 License:        PHP
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
13 # Source0-md5:  85435fc2d8f067558acc81c33a453d83
14 URL:            http://pecl.php.net/package/Net_Gopher/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Obsoletes:      php-pear-%{modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 fopen wrapper for retrieving documents via gopher protocol. Includes
24 additional function for parsing gopher directory entries.
25
26 In PECL status of this package is: %{status}.
27
28 %description -l pl.UTF-8
29 Wrapper wokół funkcji fopen pozwalający na pobieranie dokumentów za
30 pomocą protokołu gopher. Zawiera dodatkową funkcję służącą parsowaniu
31 pozycji katalogu.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38
39 %build
40 phpize
41 %configure \
42         --enable-gopher
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
48
49 install -p modules/%{extname}.so $RPM_BUILD_ROOT%{php_extensiondir}
50 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{extname}.ini
51 ; Enable %{modname} extension module
52 extension=%{extname}.so
53 EOF
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{extname}.ini
61 %attr(755,root,root) %{php_extensiondir}/%{extname}.so
This page took 0.164694 seconds and 3 git commands to generate.