]> git.pld-linux.org Git - packages/php-pear-XML_Wddx.git/blob - php-pear-XML_Wddx.spec
- updated to: 1.0.2
[packages/php-pear-XML_Wddx.git] / php-pear-XML_Wddx.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          XML
3 %define         _subclass       Wddx
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - Wddx pretty serializer and deserializer
8 Summary(pl.UTF-8):      %{_pearname} - przyzwoity serializer i deserializer Wddx
9 Name:           php-pear-%{_pearname}
10 Version:        1.0.2
11 Release:        1
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  117e6471762ebdaf033d47e36a2b6aeb
16 URL:            http://pear.php.net/package/XML_Wddx/
17 BuildRequires:  php-pear-PEAR
18 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
19 BuildRequires:  rpmbuild(macros) >= 1.300
20 Requires:       php-pear
21 Requires:       php-pear-XML_Parser >= 1.0
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 XML_Wddx does 2 things:
27 - a drop in replacement for the XML_Wddx extension (if it's not built
28   in)
29 - produce an editable wddx file (with indenting etc.) and uses CDATA,
30   rather than char tags
31
32 This package contains 2 static method:
33 - XML_Wddx:serialize($value)
34 - XML_Wddx:deserialize($value)
35
36 And should be 90% compatible with wddx_deserialize(), and the
37 deserializer will use wddx_deserialize if it is built in.
38
39 No support for recordsets is available at present in the PHP version
40 of the deserializer.
41
42 In PEAR status of this package is: %{_status}.
43
44 %description -l pl.UTF-8
45 XML_Wddx robi dwie rzeczy:
46 - zastępuje rozszerzenie XML_Wddx (jeśli nie jest wbudowane)
47 - tworzy edytowalny plik wddx (z wcięciami itp.) i używa CDATA zamiast
48   znaczników znakowych
49
50 Ten pakiet zawiera 2 statyczne metody:
51 - XML_Wddx:serialize($value)
52 - XML_Wddx:deserialize($value)
53
54 i powinien być w 90% kompatybilny z wddx_deserialize(), a deserializer
55 będzie używał wddx_deserialize jeśli zostało wbudowane.
56
57 Aktualnie nie ma obsługi dla zbiorów rekordów w wersji PHP
58 deserializera.
59
60 Ta klasa ma w PEAR status: %{_status}.
61
62 %prep
63 %pear_package_setup
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{php_pear_dir}
68 %pear_package_install
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc install.log
76 %{php_pear_dir}/.registry/*.reg
77 %{php_pear_dir}/%{_class}/*.php
This page took 0.046017 seconds and 3 git commands to generate.