]> git.pld-linux.org Git - packages/php-pear-PEAR.git/blob - php-pear-PEAR.spec
- updated to 1.3.4
[packages/php-pear-PEAR.git] / php-pear-PEAR.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _status         stable
4 %define         _pearname       %{_class}
5
6 Summary:        %{_pearname} - main PHP PEAR class
7 Summary(pl):    %{_pearname} - podstawowa klasa dla PHP PEAR
8 Name:           php-pear-%{_pearname}
9 Version:        1.3.4
10 Release:        1
11 Epoch:          1
12 License:        PHP 3.0
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  38a21bb2eabd361ebba26bbc330faea6
16 URL:            http://pear.php.net/package/PEAR/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 BuildRequires:  sed
19 Requires:       php-pear
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # this is in a comment
24 %define         _noautoreq      'pear(../PEAR/RunTest.php)'
25
26 %description
27 The PEAR package contains:
28 - the PEAR base class
29 - the PEAR_Error error handling mechanism
30 - the PEAR installer, for creating, distributing and installing
31   packages
32
33 In PEAR status of this package is: %{_status}.
34
35 %description -l pl
36 Pakiet PEAR zawiara:
37 - Podstawow± klasê PEAR
38 - Mechanizm obs³ugi b³êdów PEAR_Error
39 - PEAR installer do tworzenia, dystrybucji i instalowania pakietów
40
41 Ta klasa ma w PEAR status: %{_status}.
42
43 %package Command
44 Summary:        %{_pearname}-Command - main PHP PEAR class
45 Summary(pl):    %{_pearname}-Command - podstawowa klasa dla PHP PEAR
46 Group:          Development/Languages/PHP
47
48 %description Command
49 Command class for PEAR.
50
51 In PEAR status of this package is: %{_status}.
52
53 %description Command -l pl
54 Klasa Command dla PEAR-a.
55
56 Ta klasa ma w PEAR status: %{_status}.
57
58 %package Frontend_CLI
59 Summary:        %{_pearname}-Frontend_CLI - main PHP PEAR class
60 Summary(pl):    %{_pearname}-Frontend_CLI - podstawowa klasa dla PHP PEAR
61 Group:          Development/Languages/PHP
62 Requires:       php-pear-Archive_Tar
63 Requires:       php-pear-Console_Getopt
64 Obsoletes:      php-pear-devel
65
66 %description Frontend_CLI
67 Command Line Frontend for PEAR.
68
69 In PEAR status of this package is: %{_status}.
70
71 %description Frontend_CLI -l pl
72 Interfejs z linii poleceñ dla PEAR-a.
73
74 Ta klasa ma w PEAR status: %{_status}.
75
76 %package OS
77 Summary:        %{_pearname}-OS - main PHP PEAR class
78 Summary(pl):    %{_pearname}-OS - podstawowa klasa dla PHP PEAR
79 Group:          Development/Languages/PHP
80
81 %description OS
82 OS_Guess class for PEAR.
83
84 In PEAR status of this package is: %{_status}.
85
86 %description OS -l pl
87 Klasa OS_Guess dla PEAR-a.
88
89 Ta klasa ma w PEAR status: %{_status}.
90
91 %prep
92 %setup -q -c
93
94 #%build
95 #cd %{_pearname}-%{version}/scripts
96 #sed -e "s#@php_bin@#php#" pear.sh > pear.sh.tmp
97 #mv -f pear.sh.tmp pear.sh
98 #sed -e "s#@pear_version@#%{_version}#" pear.sh > pear.sh.tmp
99 #mv -f pear.sh.tmp pear.sh
100 #sed -e "s#@php_dir@#%{php_pear_dir}#" pear.sh > pear.sh.tmp
101 #mv -f pear.sh.tmp pear.sh
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{php_pear_dir}/{%{_class}/{Command,Frontend},OS},%{_bindir}}
106
107 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}
108 install %{_pearname}-%{version}/*.dtd $RPM_BUILD_ROOT%{php_pear_dir}
109 install %{_pearname}-%{version}/OS/*.php $RPM_BUILD_ROOT%{php_pear_dir}/OS
110 install %{_pearname}-%{version}/%{_class}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
111 install %{_pearname}-%{version}/%{_class}/Command/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Command
112 install %{_pearname}-%{version}/%{_class}/Frontend/CLI.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Frontend
113 install %{_pearname}-%{version}/scripts/pearcmd.php $RPM_BUILD_ROOT%{php_pear_dir}
114 install %{_pearname}-%{version}/scripts/pear.sh $RPM_BUILD_ROOT%{_bindir}/pear
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %dir %{php_pear_dir}
122 %{php_pear_dir}/*.php
123
124 %files Command
125 %defattr(644,root,root,755)
126 %dir %{php_pear_dir}/%{_class}/Command
127 %dir %{php_pear_dir}/%{_class}/Frontend
128 %attr(755,root,root) %{_bindir}/pear
129 %{php_pear_dir}/%{_class}/*.php
130 %{php_pear_dir}/%{_class}/Command/*.php
131 %{php_pear_dir}/*.dtd
132
133 %files Frontend_CLI
134 %defattr(644,root,root,755)
135 %{php_pear_dir}/%{_class}/Frontend/*.php
136
137 %files OS
138 %defattr(644,root,root,755)
139 %dir %{php_pear_dir}/OS
140 %{php_pear_dir}/OS/*.php
This page took 0.037038 seconds and 3 git commands to generate.