]> git.pld-linux.org Git - packages/php-pear-PEAR.git/blob - php-pear-PEAR.spec
- release 3 (rebuild with new rpm)
[packages/php-pear-PEAR.git] / php-pear-PEAR.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _pearname       %{_class}
4 Summary:        %{_class} - main php pear class
5 Summary(pl):    %{_class} - podstawowa klasa dla php pear
6 Name:           php-pear-%{_pearname}
7 Version:        0.90
8 Release:        3
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
12 URL:            http://pear.php.net/
13 BuildRequires:  rpm-php-pearprov
14 Requires:       php-pear
15 # This is temporary empty class
16 Provides:       pear(stdClass)
17 # Temporary - this is not OK:
18 Provides:       pear(parent)
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The PEAR package contains:
24 - the PEAR base class
25 - the PEAR_Error error handling mechanism
26 - the PEAR installer, for creating, distributing and installing
27   packages
28
29 %description -l pl
30 Pakiet PEAR zawiara:
31 - Postawow± klasê PEAR
32 - Mechanizm obs³ugi b³êdów PEAR_Error
33 - PEAR installer do tworzenia, dystrybucji i instalowania pakietów
34
35 %package Command
36 Summary:        %{_class} - main php pear class
37 Summary(pl):    %{_class} - podstawowa klasa dla php pear
38 Group:          Development/Languages/PHP
39 Requires:       pear(Frontend)
40
41 %description Command
42 Command class for PEAR.
43
44 %description -l pl Command
45 Klasa Command dla PEARa.
46
47 %package Frontend_CLI
48 Summary:        %{_class} - main php pear class
49 Summary(pl):    %{_class} - podstawowa klasa dla php pear
50 Group:          Development/Languages/PHP
51 Provides:       pear(Frontend)
52
53 %description Frontend_CLI
54 Command Line Frontend for PEAR.
55
56 %description -l pl Frontend_CLI
57 Interfejs z linii poleceñ dla PEAR-a.
58
59 %package OS
60 Summary:        %{_class} - main php pear class
61 Summary(pl):    %{_class} - podstawowa klasa dla php pear
62 Group:          Development/Languages/PHP
63
64 %description OS
65 OS_Guess class for PEAR.
66
67 %description -l pl OS
68 Klasa OS_Guess dla PEARa.
69
70 %prep
71 %setup -q -c
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{php_pear_dir}/{%{_class}/{Command,Frontend},OS}
76
77 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}
78 install %{_pearname}-%{version}/OS/*.php $RPM_BUILD_ROOT%{php_pear_dir}/OS
79 install %{_pearname}-%{version}/%{_class}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
80 install %{_pearname}-%{version}/%{_class}/Command/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Command
81 install %{_pearname}-%{version}/%{_class}/Frontend/CLI.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Frontend
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %{php_pear_dir}/*.php
89
90 %files Command
91 %defattr(644,root,root,755)
92 %dir %{php_pear_dir}/%{_class}/Command
93 %dir %{php_pear_dir}/%{_class}/Frontend
94 %{php_pear_dir}/%{_class}/*.php
95 %{php_pear_dir}/%{_class}/Command/*.php
96
97 %files Frontend_CLI
98 %defattr(644,root,root,755)
99 %{php_pear_dir}/%{_class}/Frontend/*.php
100
101 %files OS
102 %defattr(644,root,root,755)
103 %dir %{php_pear_dir}/OS
104 %{php_pear_dir}/OS/*.php
This page took 0.034226 seconds and 3 git commands to generate.