]> git.pld-linux.org Git - SPECS.git/blob - php-pear-HTML_Template_Xipe.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / php-pear-HTML_Template_Xipe.spec
1 %define         _class          HTML
2 %define         _subclass       Template
3 %define         _status         stable
4 %define         _pearname       %{_class}_%{_subclass}_Xipe
5 Summary:        %{_pearname} - A simple, fast and powerful template engine
6 Summary(pl.UTF-8):      %{_pearname} - prosty, szybki i potężny system szablonów
7 Name:           php-pear-%{_pearname}
8 Version:        1.7.6
9 Release:        5
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
13 # Source0-md5:  a5b291d4e64e603f9e58ce0f517e3600
14 URL:            http://pear.php.net/package/HTML_Template_Xipe/
15 BuildRequires:  php-pear-PEAR
16 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
17 BuildRequires:  rpmbuild(macros) >= 1.300
18 Requires:       php-pear
19 Requires:       php-pear-Log >= 1.8
20 Requires:       php-pear-Tree >= 0.2
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The template engine is a compiling engine, all templates are compiled
26 into PHP-files. This will make the delivery of the files faster on the
27 next request, since the template doesn't need to be compiled again. If
28 the template changes it will be recompiled.
29
30 There is no new template language to learn. Beside the default mode,
31 there is a set of constructs since version 1.6 which allow you to edit
32 your templates with WYSIWYG editors.
33
34 By default the template engine uses indention for building blocks (you
35 can turn that off). This feature was inspired by Python and by the
36 need I felt to force myself to write proper HTML-code, using proper
37 indentions, to make the code better readable.
38
39 Every template is customizable in multiple ways. You can configure
40 each template or an entire directory to use different delimiters,
41 caching parameters, etc. via either an XML-file or a XML-chunk which
42 you simply write anywhere inside the tpl-code.
43
44 Using the Cache the final file can also be cached (i.e. a resulting
45 HTML-file). The caching options can be customized as needed. The cache
46 can reduce the server load by very much, since the entire php-file
47 doesn't need to be processed again, the resulting client-readable data
48 are simply delivered right from the cache (the data are saved using
49 php's output buffering).
50
51 The template engine is prepared to be used for multi-language
52 applications too. If you i.e. use the PEAR::I18N for translating the
53 template, the compiled templates need to be saved under a different
54 name for each language. The template engine is prepared for that too,
55 it saves the compiled template including the language code if required
56 (i.e. a compiled index.tpl which is saved for english gets the
57 filename index.tpl.en.php).
58
59 In PEAR status of this package is: %{_status}.
60
61 %description -l pl.UTF-8
62 Ten silnik szablonów to system kompilujący - wszystkie szablony są
63 kompilowane do plików PHP. Czyni to dostarczanie plików szybszym przy
64 kolejnych żądaniach, ponieważ szablony nie muszą być ponownie
65 kompilowane. Jeśli szablon zmieni się, musi być przekompilowany.
66
67 Nie trzeba się uczyć nowego języka szablonów. Poza trybem domyślnym,
68 są zestawy konstrukcji od wersji 1.6, pozwalające na edycję szablonów
69 edytorami WYSIWYG.
70
71 Domyślnie silnik używa wcięć do tworzenia bloków (można to wyłączyć).
72 Ta własność została zainspirowana Pythonem i potrzebą autora zmuszenia
73 się do pisania właściwego kodu HTML, przy użyciu właściwych wcięć, aby
74 uczynić kod bardziej czytelnym.
75
76 Każdy szablon można dostosować na wiele sposobów. Można konfigurować
77 każdy szablon lub cały katalog, aby używały różnych ograniczników,
78 parametrów buforowania itp. - poprzez plik XML lub fragment XML
79 osadzony gdziekolwiek wewnątrz kodu tpl.
80
81 Ostateczny plik (wynikowy plik HTML) także może być buforowany. Opcje
82 buforowania mogą być w miarę potrzeby modyfikowane. Buforowanie może
83 znacznie ograniczyć obciążenie serwera, bo nie musi być ponownie
84 przetwarzany cały plik PHP - czytelne dla klienta dane wynikowe są po
85 prostu dostarczane z bufora (dane są zapisywane przy użyciu mechanizmu
86 buforowania wyjścia w PHP).
87
88 Ten silnik jest przygotowany na używanie także w aplikacjach
89 wielojęzycznych. W przypadku używania PEAR::I18N do tłumaczenia
90 szablonu, skompilowane szablony muszą być zapisywane pod różną nazwą
91 dla każdego języka. Silnik także jest na to przygotowany - w razie
92 potrzeby zapisuje skompilowany szablon z użyciem kodu język (np.
93 skompilowany index.tpl zapisany dla języka angielskiego otrzymuje
94 nazwę index.tpl.en.php).
95
96 Ta klasa ma w PEAR status: %{_status}.
97
98 %prep
99 %pear_package_setup
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{php_pear_dir}
104 %pear_package_install
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc install.log
112 %dir %{php_pear_dir}/%{_class}/%{_subclass}/Xipe
113 %dir %{php_pear_dir}/%{_class}/%{_subclass}/Xipe/Filter
114 %{php_pear_dir}/.registry/*.reg
115 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
116 %{php_pear_dir}/%{_class}/%{_subclass}/Xipe/*.php
117 %{php_pear_dir}/%{_class}/%{_subclass}/Xipe/Filter/*.php
This page took 0.217072 seconds and 3 git commands to generate.