]> git.pld-linux.org Git - packages/php-pear-HTML_Template_IT.git/blob - php-pear-HTML_Template_IT.spec
347df59fca266c6c6f5d41daa1ba5cbab7b7e5ed
[packages/php-pear-HTML_Template_IT.git] / php-pear-HTML_Template_IT.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       Template
4 %define         _pearname       %{_class}_%{_subclass}_IT
5 Summary:        %{_pearname} - Integrated Templates
6 Summary(pl):    %{_pearname}
7 Name:           php-pear-%{_pearname}
8 Version:        1.0
9 Release:        1
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
13 URL:            http://pear.php.net/
14 BuildRequires:  rpm-php-pearprov
15 Requires:       php-pear
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 HTML_Template_IT: Simple template API. The Isotemplate API is somewhat
21 tricky for a beginner although it is the best one you can build.
22 template::parse() [phplib template = Isotemplate] requests you to name
23 a source and a target where the current block gets parsed into. Source
24 and target can be block names or even handler names. This API gives
25 you a maximum of fexibility but you always have to know what you do
26 which is quite unusual for php skripter like me. I noticed that I do
27 not any control on which block gets parsed into which one. If all
28 blocks are within one file, the script knows how they are nested and
29 in which way you have to parse them. IT knows that inner1 is a child
30 of block2, there's no need to tell him about this. Features :
31  - Nested blocks,
32  - Include external file,
33  - Custom tags format (default {mytag}).
34
35 HTML_Template_ITX: With this class you get the full power of the
36 phplib template class. You may have one file with blocks in it but you
37 have as well one main file and multiple files one for each block. This
38 is quite usefull when you have user configurable websites. Using
39 blocks not in the main template allows you to modify some parts of
40 your layout easily.
41
42 %prep
43 %setup -q -c
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
48
49 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %dir %{php_pear_dir}/%{_class}/%{_subclass}
57 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.070798 seconds and 2 git commands to generate.