]> git.pld-linux.org Git - packages/php-pear-HTML_QuickForm.git/blob - php-pear-HTML_QuickForm.spec
- initial (this CVS is annoing now...)
[packages/php-pear-HTML_QuickForm.git] / php-pear-HTML_QuickForm.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       QuickForm
4 %define         _pearname       %{_class}_%{_subclass}
5 Summary:        %{_class}_%{_subclass} - methods for creating, validating, processing HTML forms
6 Summary(pl):    %{_class}_%{_subclass} - metody do tworzenia, korekcji i przetwarzania formularzy HTML
7 Name:           php-pear-%{_pearname}
8 Version:        2.3
9 Release:        1
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
13 BuildRequires:  rpm-php-pearprov
14 URL:            http://pear.php.net/
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The PEAR::HTML_QuickForm package provides methods for creating,
20 validating, processing HTML forms. Features:
21 - Creates xHTML compliant form elements of various type.
22 - Allows you to choose an unlimited number of html attributes.
23 - Allows you to create your own custom elements using your own
24   classes.
25 - Process form values (you should override the process method).
26 - Creates javascript validation code using regular expression.
27 - Server-side validation too.
28 - Allows you to create your own validation rules.
29 - Manages file uploads.
30 - Allows you to freeze some elements in your form.
31 - Allows you to customize the look of your form in many ways.
32 - Template-like form elements customization...
33
34 %description -l pl
35
36 %prep
37 %setup -q -c
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 cd %{_pearname}-%{version}
42
43 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
44
45 install *.php                   $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/
46 install %{_subclass}/*.php      $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %dir %{php_pear_dir}/%{_class}/%{_subclass}
54 %doc %{_pearname}-%{version}/docs/*
55 %{php_pear_dir}/%{_class}/*.php
56 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.032406 seconds and 4 git commands to generate.