]> git.pld-linux.org Git - SPECS.git/blob - php-pear-Archive_Tar.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / php-pear-Archive_Tar.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # bootstrap build without PEAR installed (for first php-pear-PEAR installation)
4
5 %define         status          stable
6 %define         pearname        Archive_Tar
7 Summary:        %{pearname} - Tar file management class
8 Summary(pl.UTF-8):      %{pearname} - klasa do zarządzania plikami Tar
9 Name:           php-pear-%{pearname}
10 Version:        1.4.9
11 Release:        1
12 License:        New BSD
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{pearname}-%{version}.tgz
15 # Source0-md5:  55d09b767bfaff475cfc99432d69856d
16 URL:            http://pear.php.net/package/Archive_Tar/
17 %if %{without bootstrap}
18 BuildRequires:  php-pear-PEAR
19 %endif
20 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
21 BuildRequires:  rpmbuild(macros) >= 1.580
22 Requires:       php-pear
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This class provides handling of tar files in PHP. It supports
28 creating, listing, extracting and adding to tar files. Gzip support is
29 available if PHP has the zlib extension built-in or loaded.
30
31 In PEAR status of this package is: %{status}.
32
33 %description -l pl.UTF-8
34 Ta klasa udostępnia obsługę plików tar w PHP. Pozwala na tworzenie,
35 przeglądanie zawartości, rozpakowywanie i dodawanie plików do archiwów
36 tar. Obsługa kompresji gzip jest dostępna, jeśli do PHP jest
37 zainstalowany moduł rozszerzenia zlib.
38
39 Ta klasa ma w PEAR status: %{status}.
40
41 %prep
42 %if %{without bootstrap}
43 %pear_package_setup
44 %else
45 %setup -q -c -n %{pearname}-%{version}
46 %{__mv} %{pearname}-%{version}/* .
47 %endif
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{php_pear_dir}
52
53 %if %{without bootstrap}
54 %pear_package_install
55 %else
56 cp -pr Archive $RPM_BUILD_ROOT%{php_pear_dir}
57 %endif
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %if %{without bootstrap}
65 %doc install.log docs/%{pearname}/docs/*
66 %{php_pear_dir}/.registry/archive_tar.reg
67 %endif
68 %{php_pear_dir}/Archive/Tar.php
This page took 0.858599 seconds and 3 git commands to generate.