]> git.pld-linux.org Git - SPECS.git/blob - php-horde-Horde_Editor.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / php-horde-Horde_Editor.spec
1 # TODO
2 # - localize files
3 # - system ckeditor
4 %define         status          stable
5 %define         pearname        Horde_Editor
6 Summary:        %{pearname} - Horde Editor API
7 Name:           php-horde-Horde_Editor
8 Version:        1.0.0
9 Release:        1
10 License:        LGPL
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.horde.org/get/%{pearname}-%{version}.tgz
13 # Source0-md5:  abbd163109e96827b9466fcc5aaf4800
14 URL:            https://github.com/horde/horde/tree/master/framework/Editor/
15 BuildRequires:  php-channel(pear.horde.org)
16 BuildRequires:  php-horde-Horde_Role
17 BuildRequires:  php-packagexml2cl
18 BuildRequires:  php-pear-PEAR >= 1:1.7.0
19 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
20 BuildRequires:  rpmbuild(macros) >= 1.580
21 Requires:       php-channel(pear.horde.org)
22 Requires:       php-horde-Horde_Browser < 2.0.0
23 Requires:       php-horde-Horde_Core < 2.0.0
24 Requires:       php-horde-Horde_Exception < 2.0.0
25 Requires:       php-horde-Horde_Serialize < 2.0.0
26 Requires:       php-pear
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         hordedir        /usr/share/horde
31
32 %description
33 The Horde_Editor package provides an API to generate the code
34 necessary for embedding javascript RTE editors in a web page.
35
36 In PEAR status of this package is: %{status}.
37
38 %prep
39 %pear_package_setup
40
41 mv ./%{php_pear_dir}/www/horde .
42
43 %build
44 packagexml2cl package.xml > ChangeLog
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{php_pear_dir},%{hordedir}}
49 %pear_package_install
50
51 cp -a horde/* $RPM_BUILD_ROOT%{hordedir}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog install.log
59 %{php_pear_dir}/.registry/.channel.*/*.reg
60 %{php_pear_dir}/Horde/Editor
61 %{php_pear_dir}/Horde/Editor.php
62
63 %{hordedir}/js/LICENSE.html
64 %{hordedir}/js/ckeditor.js
65 %{hordedir}/js/ckeditor_basic.js
66 %{hordedir}/js/config.js
67 %{hordedir}/js/contents.css
68 %{hordedir}/js/images/spacer.gif
69
70 %dir %{hordedir}/js/lang
71 %{hordedir}/js/lang/*.js
72
73 %{hordedir}/js/plugins/a11yhelp
74 %{hordedir}/js/plugins/about
75 %{hordedir}/js/plugins/autogrow
76 %{hordedir}/js/plugins/clipboard
77 %{hordedir}/js/plugins/colordialog
78 %{hordedir}/js/plugins/dialog
79 %{hordedir}/js/plugins/div
80 %{hordedir}/js/plugins/find
81 %{hordedir}/js/plugins/flash
82 %{hordedir}/js/plugins/forms
83 %{hordedir}/js/plugins/iframedialog
84 %{hordedir}/js/plugins/image
85 %{hordedir}/js/plugins/link
86 %{hordedir}/js/plugins/liststyle
87 %{hordedir}/js/plugins/pagebreak
88 %{hordedir}/js/plugins/pastefromword
89 %{hordedir}/js/plugins/pastetext
90 %{hordedir}/js/plugins/scayt
91 %{hordedir}/js/plugins/showblocks
92 %{hordedir}/js/plugins/smiley
93 %{hordedir}/js/plugins/specialchar
94 %{hordedir}/js/plugins/styles
95 %{hordedir}/js/plugins/syntaxhighlight
96 %{hordedir}/js/plugins/table
97 %{hordedir}/js/plugins/tableresize
98 %{hordedir}/js/plugins/tabletools
99 %{hordedir}/js/plugins/templates
100 %{hordedir}/js/plugins/uicolor
101 %{hordedir}/js/plugins/wsc
102
103 %dir %{hordedir}/js/skins
104 %{hordedir}/js/skins/kama
105 %{hordedir}/js/skins/office2003
106 %{hordedir}/js/skins/v2
107 %{hordedir}/js/themes/default/theme.js
This page took 1.921178 seconds and 3 git commands to generate.