]> git.pld-linux.org Git - SPECS.git/blob - php-gnutls.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / php-gnutls.spec
1 %define         _modname        gnutls
2 %define _pre    rc1
3 Summary:        GnuTLS PHP Module
4 Summary(pl.UTF-8):      Moduł PHP GnuTLS
5 Name:           php-%{_modname}
6 Version:        0.3
7 Release:        0.%{_pre}.1
8 License:        GPL
9 Group:          Development/Languages/PHP
10 Source0:        http://files.openvcp.org/mod%{name}-%{version}-%{_pre}.tar.gz
11 # Source0-md5:  2a52affb9b2a5271558ffc2baaf9aa56
12 URL:            http://www.openvcp.org/
13 BuildRequires:  autoconf
14 BuildRequires:  gnutls-devel
15 BuildRequires:  php-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.394
17 %{?requires_php_extension}
18 Requires:       php-common >= 4:5.0.4
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 GnuTLS PHP Module.
23
24 %description -l pl.UTF-8
25 Moduł PHP GnuTLS.
26
27 %prep
28 %setup -q -n mod%{name}-%{version}-%{_pre}
29
30 %build
31 %{__autoconf}
32 %configure \
33         --with-phpsrc=%{php_includedir}
34
35 %{__make}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{php_extensiondir},%{php_sysconfdir}/conf.d}
40
41 install %{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
42
43 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
44 ; Enable %{_modname} extension module
45 extension=%{_modname}.so
46 EOF
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %php_webserver_restart
53
54 %postun
55 if [ "$1" = 0 ]; then
56         %php_webserver_restart
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
62 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.228789 seconds and 3 git commands to generate.