]> git.pld-linux.org Git - SPECS.git/blob - php-dbg-cli.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / php-dbg-cli.spec
1 #
2 # TODO:
3 #               command.cpp:761: warning: overflow in implicit constant conversion
4 #               command.cpp:768: warning: overflow in implicit constant conversion
5 #               signed overflow is an undefined bahaviour and gcc optimizer
6 #               can produce random code ;)
7 #
8 #               -Wl,--as-needed breaks ./configure.
9 #
10 Summary:        dbg-cli - a free front-end for dbg PHP debbuger
11 Summary(pl.UTF-8):      dbg-cli - wolnodostępny frontend dla debuggera PHP dbg
12 Name:           php-dbg-cli
13 Version:        2.15.5
14 Release:        0.1
15 License:        The DBG License Version 3.0
16 Group:          Development/Languages/PHP
17 Source0:        http://dl.sourceforge.net/dbg2/dbg-cli-%{version}-src.tar.gz
18 # Source0-md5:  10524eaf90dd177c709deb981419fcf4
19 Patch0:         %{name}-syslibs.patch
20 URL:            http://dd.cron.ru/dbg/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool
25 BuildRequires:  ncurses-devel
26 BuildRequires:  pcre-devel
27 BuildRequires:  readline-devel
28 Obsoletes:      dbg-cli
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # see TODO
32 %define         filterout_ld -Wl,--as-needed
33
34 %description
35 DBG is a a full-featured PHP debugger, an interactive tool that helps
36 you debugging PHP scripts. It works on a production and/or development
37 WEB server and allows you debug your scripts locally or remotely, from
38 an IDE or console.
39
40 This package contains DBG CLI - a free front-end for dbg.
41
42 %description -l pl.UTF-8
43 DBG to w pełni funkcjonalny debugger dla PHP - interaktywne narzędzie
44 pomagające przy diagnostyce skryptów w PHP. Działa zarówno na
45 produkcyjnym jak i rozwojowym serwerze WWW, pozwala na śledzenie
46 skryptów lokalnie jak i zdalnie, z poziomu IDE lub konsoli.
47
48 Ten pakiet zawiera DBG CLI - wolnodostępny frontend dla dbg.
49
50 %prep
51 %setup -q -n dbg-cli-%{version}-src
52 %patch0 -p1
53 rm -rf pcre getopt
54
55 %build
56 %{__libtoolize}
57 %{__aclocal} -I config
58 %{__autoheader}
59 %{__automake}
60 %{__autoconf}
61 %configure
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 # nothing needs those
71 rm -rf $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc COPYING AUTHORS README
79 %attr(755,root,root) %{_bindir}/dbg-cli
This page took 0.16881 seconds and 3 git commands to generate.