]> git.pld-linux.org Git - packages/php-adodb.git/blob - php-adodb.spec
- remove invalid Source0Download
[packages/php-adodb.git] / php-adodb.spec
1 %include        /usr/lib/rpm/macros.php
2 %define ver     %(echo %{version} | tr -d .)
3 Summary:        Unique interface to access different SQL databases
4 Summary(pl):    Jednolity inferfejs dostêpu do baz danych SQL
5 Name:           adodb
6 Version:        4.67
7 Release:        1.17
8 License:        dual licensed using BSD-Style and LGPL
9 Group:          Libraries
10 Source0:        http://dl.sourceforge.net/adodb/%{name}%{ver}.tgz
11 # Source0-md5:  679d4fac06126707f4bf636508e9ec8a
12 Patch0:         %{name}-paths.patch
13 URL:            http://adodb.sourceforge.net/
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 Requires:       php-common
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _noautoreq 'pear(\.\./.*)' 'pear(adodb.*)' 'pear(test.*)' 'pear(.*.inc.php)'
20 %define         _noautoprov 'pear(adodb/.*)'
21
22 %define         _appdir         %{_datadir}/php/%{name}
23
24 %description
25 PHP's database access functions are not standardized. This creates a
26 need for a database class library to hide the differences between the
27 different databases (encapsulate the differences) so we can easily
28 switch databases.
29
30 It currently supports MySQL, Interbase, Oracle, Microsoft SQL Server,
31 Sybase, PostgreSQL, Foxpro, Access, ADO and ODBC.
32
33 %description -l pl
34 Funkcje dostêpu do baz danych w PHP nie s± ustandaryzowane. To
35 powoduje i¿ potrzebna jest biblioteka dostarczaj±ca jednolite funkcje
36 ukrywaj±ca ró¿nice pomiêdzy ró¿nymi bazami dziêki czemu ³atwo mo¿na
37 zmieniaæ bazy.
38
39 Aktualnie wspiera MySQL, Interbase, Oracle, Microsoft SQL Server,
40 Sybase, PostgreSQL, Foxpro, Access, ADO i ODBC.
41
42 %package -n php-pear-Auth_Container_ADOdb
43 Summary:        ADOdb container for PEAR Auth
44 Group:          Development/Languages/PHP
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       %{name}-pear
47 Requires:       php-pear-Auth
48
49 %description -n php-pear-Auth_Container_ADOdb
50 Storage driver for fetching login data from a database using
51 ADOdb-PHP.
52
53 This storage driver can use all databases which are supported by the
54 ADBdb DB abstraction layer to fetch login data.
55
56 %package pear
57 Summary:        PEAR DB Emulation Layer for ADODB.
58 Group:          Development/Languages/PHP
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       php-pear
61
62 %description pear
63 PEAR DB Emulation Layer for ADODB.
64
65 %package tests
66 Summary:        Tests for ADODB
67 Group:          Development/Languages/PHP
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69
70 %description tests
71 Tests for ADODB.
72
73 %description tests -l pl
74 Testy dla ADODB.
75
76 %prep
77 %setup -q -n %{name}
78 # undos the source
79 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
80
81 %patch0 -p1
82 mv pear/{readme.Auth.txt,README}
83 rm -rf session/old
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{_appdir}/{drivers,datadict,perf,lang,session,xsl}
88
89 cp -a *.php *.dtd drivers datadict tests lang perf session xsl \
90         $RPM_BUILD_ROOT%{_appdir}
91
92 install -d $RPM_BUILD_ROOT%{php_pear_dir}/Auth/Container
93 cp -a pear/Auth/Container/ADOdb.php $RPM_BUILD_ROOT%{php_pear_dir}/Auth/Container
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %triggerpostun -- adodb < 4.67-1.17
99 %banner -e %{name} <<EOF
100 ADODB includes have been moved to %{_appdir}.
101 If you're too lazy to fix your code, make compat symlink:
102 ln -s %{_appdir} %{php_pear_dir}/adodb
103 EOF
104 #'
105
106 %files
107 %defattr(644,root,root,755)
108 %dir %{_appdir}
109 %{_appdir}/datadict
110 %{_appdir}/drivers
111 %{_appdir}/lang
112 %{_appdir}/perf
113 %{_appdir}/server.php
114 %{_appdir}/session
115 %{_appdir}/xmlschema.dtd
116 %{_appdir}/xsl
117
118 %{_appdir}/adodb-csvlib.inc.php
119 %{_appdir}/adodb-datadict.inc.php
120 %{_appdir}/adodb-error.inc.php
121 %{_appdir}/adodb-errorhandler.inc.php
122 %{_appdir}/adodb-exceptions.inc.php
123 %{_appdir}/adodb-iterator.inc.php
124 %{_appdir}/adodb-lib.inc.php
125 %{_appdir}/adodb-pager.inc.php
126 %{_appdir}/adodb-perf.inc.php
127 %{_appdir}/adodb-php4.inc.php
128 %{_appdir}/adodb-time.inc.php
129 %{_appdir}/adodb-xmlschema.inc.php
130 %{_appdir}/adodb.inc.php
131 %{_appdir}/toexport.inc.php
132 %{_appdir}/tohtml.inc.php
133
134 %files tests
135 %defattr(644,root,root,755)
136 %{_appdir}/tests
137 %{_appdir}/pivottable.inc.php
138 %{_appdir}/rsfilter.inc.php
139
140 %files pear
141 %defattr(644,root,root,755)
142 %{_appdir}/adodb-pear.inc.php
143 %{_appdir}/adodb-errorpear.inc.php
144
145 %files -n php-pear-Auth_Container_ADOdb
146 %defattr(644,root,root,755)
147 %doc pear/README
148 %{php_pear_dir}/Auth/Container/ADOdb.php
This page took 0.038031 seconds and 4 git commands to generate.