]> git.pld-linux.org Git - packages/pg_activity.git/blob - pg_activity.spec
7f68ee7269d7c2591a7e9cb38621640caf76c3d9
[packages/pg_activity.git] / pg_activity.spec
1 # TODO:
2 #  Fix FATAL: 'PSProcess' object has no attribute 'get_memory_percent'
3 #  Move man dir to proper place ?
4
5 # NOTE:
6 #  Not sure if should be build as separte packages for py 3.x / 2.x  and binary package ?
7 #  Are modules used by other soft? If not just switch to py 3.x when there is release available
8
9 # Conditional build:
10 %bcond_without  tests   # do not perform "make test"
11
12 %define         module  pgactivity
13 Summary:        A top like application for PostgreSQL server activity monitoring
14 Name:           pg_activity
15 Version:        1.2.0
16 Release:        0.1
17 License:        distributable
18 Group:          Libraries/Python
19 Source0:        https://github.com/julmon/pg_activity/archive/v%{version}.tar.gz
20 # Source0-md5:  1c75bdc026312b322e24fe6492ce6b5f
21 URL:            https://github.com/julmon/pg_activity
22 BuildRequires:  python-psutil
23 BuildRequires:  python-psycopg2 >= 2.2.1
24 BuildRequires:  python-setuptools
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.612
27 Requires:       python-modules
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 htop like application for PostgreSQL server activity monitoring
33
34 %description -l pl.UTF-8
35 Podobna do htop aplikacja monitorująca aktywność PostgresSQL
36
37 %prep
38 %setup -q
39
40 %build
41 %{__python} setup.py build %{?with_tests:test} \
42         --with-man
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 %{__python} setup.py install \
47         --skip-build \
48         --optimize=2 \
49         --root=$RPM_BUILD_ROOT
50
51 %py_postclean
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README.md
59 %attr(755,root,root) %{_bindir}/pg_activity
60 %dir %{py_sitescriptdir}/%{module}
61 %{py_sitescriptdir}//%{module}/*.py[co]
62 %{py_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.057768 seconds and 3 git commands to generate.