]> git.pld-linux.org Git - packages/perl.git/blob - perl.spec
- added "Group(pl)"
[packages/perl.git] / perl.spec
1 Summary:     Practical Extraction and Report Language
2 Summary(de): Praktische Extraktions- und Berichtsprache 
3 Summary(fr): Practical Extraction and Report Language (Perl)
4 Summary(pl): Practical Extraction and Report Language (Perl)
5 Summary(tr): Kabuk yorumlama dili
6 Name:        perl
7 %define      perlver 5.005
8 %define      perlrel 02
9 %define      perlthread -thread
10 Version:     %{perlver}_%{perlrel}
11 Release:     2
12 Copyright:   GPL
13 Group:       Utilities/Text
14 Group(pl):   Narzêdzia/Tekst
15 Source:      ftp://ftp.funet.fi/pub/languages/perl/CPAN/src/5.0/%{name}%{version}.tar.gz
16 Patch:       perl-noroot_install.patch
17 URL:         http://www.perl.org/
18 Requires:    csh
19 Buildroot:   /tmp/%{name}-%{version}-root
20
21 %description
22 Perl is an interpreted language optimized for scanning arbitrary text
23 files, extracting information from those text files, and printing reports
24 based on that information.  It's also a good language for many system
25 management tasks.  The language is intended to be practical (easy to use,
26 efficient, complete) rather than beautiful (tiny, elegant, minimal).
27
28 This version has support for threads compiled in.
29
30 %description -l de
31 Perl ist eine Interpreter-Sprache, die zum Durchsuchen beliebiger Text-
32 dateien, Extrahieren von Informationen aus diesen Dateien und Drucken von
33 auf diesen Informationen basierenden Berichten optimiert ist. Die Sprache
34 eignet sich außerdem für viele Systemverwaltungsaufgaben. Sie ist eher 
35 praktisch (einfache Anwendung,effizient, vollständig) als schön (winzig,
36 elegant, minimal).
37
38 %description -l fr
39 Perl est un langage interprété, optimisé pour filtrer des fichiers texte,
40 extraire des informations de ces fichiers, et imprimer des rapports basés
41 sur ces informations. C'est aussi un bon langage pour de nombreuses procédures
42 de gestion système. Ce langage se veut pratique (simple à utiliser, efficace,
43 complet) autant qu'agréable (conscrit, élégant, minimal).
44
45 %description -l pl
46 Perl jest jêzykiem przeznaczonym do skanowania plików tekstowych, wyci±gania
47 z nich informacji i drukowania raportu bazuj±cego na tych informacjach. Jest
48 równie¿ doskona³ym jêzykiem dla wielu narzêdzi do nadzoru systemu. Jêzyk ten
49 jest w zamierzeniu praktycznym (³atwym w u¿yciu, efektywnym, kompletnym) 
50 bardziej ni¿ piêkny ;) (skromny, elegancki, minimalny).
51
52 %description -l tr
53 Perl, metin dosyalarýný taramak, bu metin dosyalarýndan bilgi çýkarmak ve
54 bu bilgiye dayalý raporlar hazýrlamak icin geliþtirilmiþ bir yorumlamalý
55 dildir. Ayrýca pek çok sistem yönetimi görevleri için de yararlý yetenekleri
56 vardýr. Perl, güzel (ufak, zarif, minimum) olmaktan çok, pratik olmaya
57 yönelik (kullanýmý kolay, verimli, eksiksiz) olarak tasarlanmýþtýr.
58
59 %package -n sperl
60 Summary:     Practical Extraction and Report Language (SUID root binary)
61 Summary(pl): Practical Extraction and Report Language (SUID root binaria)
62 Group:       Utilities/Text
63 Group(pl):   Narzêdzia/Tekst
64 Requires:    %{name} = %{version}
65
66 %description -n sperl
67 Practical Extraction and Report Language (SUID root binary).
68
69 %description -n sperl -l pl
70 Practical Extraction and Report Language (SUID root binaria).
71
72 %prep
73 %setup -q -n %{name}%{version}
74 %patch -p1
75
76 %build
77 # this is gross
78 cat > config.over <<EOF
79 installprefix=$RPM_BUILD_ROOT/usr
80 test -d \$installprefix || mkdir \$installprefix
81 test -d \$installprefix/bin || mkdir \$installprefix/bin
82 installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
83 installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
84 installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
85 installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
86 installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
87 installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
88 installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
89 installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
90 EOF
91
92 sh Configure -des -Dprefix=/usr -Darchname=${RPM_ARCH}-linux -Dd_dosuid \
93         -Ud_setresuid -Ud_setresgid -Dusethreads -Doptimize="$RPM_OPT_FLAGS"
94
95 make
96
97 # Strip binaries (done now rather than at install)
98 strip perl
99 strip suidperl
100 strip x2p/a2p
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT
105
106 make install
107 install utils/pl2pm $RPM_BUILD_ROOT/usr/bin/pl2pm
108
109 (cd /usr/include ;
110 PERL5LIB=$RPM_BUILD_ROOT/usr/lib/perl5 $RPM_BUILD_ROOT/usr/bin/perl $RPM_BUILD_ROOT/usr/lib/perl5/%{perlver}%{perlrel}/${RPM_ARCH}-linux%{perlthread} \
111       $RPM_BUILD_ROOT/usr/bin/h2ph \
112       -d $RPM_BUILD_ROOT/usr/lib/perl5/${RPM_ARCH}-linux/%{perlver}%{perlrel}/ \
113       *.h sys/*.h linux/*.h asm/*.h net/*.h netinet/*.h arpa/*.h
114 )
115
116 cd $RPM_BUILD_ROOT/usr/lib/perl5/%{perlver}%{perlrel}/${RPM_ARCH}-linux%{perlthread}/
117 mv Config.pm Config.pm.old
118 sed "s|$RPM_BUILD_ROOT||" < Config.pm.old > Config.pm
119 rm -f Config.pm.old
120
121 mv $RPM_BUILD_ROOT/usr/lib/perl5/5.00502/man/man3 $RPM_BUILD_ROOT/usr/man
122
123 find $RPM_BUILD_ROOT/usr/lib/perl5 -name \*.so -exec strip --strip-debug {} \;
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644, root, root, 755)
130 %doc README Change*
131
132 %attr(755, root, root) /usr/bin/a2p
133 %attr(755, root, root) /usr/bin/c2ph
134 %attr(755, root, root) /usr/bin/find2perl
135 %attr(755, root, root) /usr/bin/h2ph
136 %attr(755, root, root) /usr/bin/h2xs
137 %attr(755, root, root) /usr/bin/perl
138 %attr(755, root, root) /usr/bin/perl5.00502
139 %attr(755, root, root) /usr/bin/perlbug
140 %attr(755, root, root) /usr/bin/perlcc
141 %attr(755, root, root) /usr/bin/perldoc
142 %attr(755, root, root) /usr/bin/pl2pm
143 %attr(755, root, root) /usr/bin/pod2html
144 %attr(755, root, root) /usr/bin/pod2latex
145 %attr(755, root, root) /usr/bin/pod2man
146 %attr(755, root, root) /usr/bin/pod2text
147 %attr(755, root, root) /usr/bin/pstruct
148 %attr(755, root, root) /usr/bin/s2p
149 %attr(755, root, root) /usr/bin/splain
150
151 %attr(-,root,root,755) /usr/lib/perl5
152 %attr(644, root,  man) /usr/man/man[13]/*
153
154 %files -n sperl
155 %attr(4711, root, root) /usr/bin/sperl5.00502
156 %attr(4711, root, root) /usr/bin/suidperl
157
158 %changelog
159 * Mon Oct 26 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
160   [5.005_02-2]
161 - added using $RPM_OPT_FLAGS during compile,
162 - added stripping modules,
163 - added URL,
164 - added sperl subpackage with suid perl binaries.
165
166 * Tue Sep 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
167   [5.005_02-1]
168 - updated to 5.005_02
169   (based on Ian Macdonald <ianmacd@xs4all.nl> spec files),
170 - install -d instead mkdir -p,
171 - added %defattr, but It's still unable to build from non root's account,
172 - man3 subdirectory moved to /usr/man/man3,
173 - minor modifications of spec file.   
174
175 * Mon Jun 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
176   [5.005_01-1]
177 - added pl translation,
178 - moved %changelog to end of spec,
179 - removed all old patches. 
180
181 * Fri May 08 1998 Cristian Gafton <gafton@redhat.com>
182 - added a patch to correct the .ph constructs unless defined (foo) to read
183   unless(defined(foo))
184
185 * Thu May 07 1998 Prospector System <bugs@redhat.com>
186 - translations modified for de, fr, tr
187
188 * Tue Mar 10 1998 Cristian Gafton <gafton@redhat.com>
189 - fixed strftime problem
190
191 * Sun Mar 08 1998 Cristian Gafton <gafton@redhat.com>
192 - added a patch to fix a security race
193 - do not use setres[ug]id - those are not implemented on 2.0.3x kernels
194
195 * Mon Mar 02 1998 Cristian Gafton <gafton@redhat.com>
196 - upgraded to 5.004_04 - 5.004_01 had some nasty memory leaks.
197 - fixed the spec file to be version-independent
198
199 * Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
200 - Config.pm wasn't right do to the builtrooting
201
202 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
203 - fixed arch-specfic part of spec file
204
205 * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
206 - updated to perl 5.004_01
207 - users a build root
208
209 * Thu Jun 12 1997 Erik Troan <ewt@redhat.com>
210 - built against glibc
211
212 * Tue Apr 22 1997 Erik Troan <ewt@redhat.com>
213 - Incorporated security patch from Chip Salzenberg <salzench@nielsenmedia.com>
214
215 * Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
216 1) Use -Darchname=i386-linux 
217 2) Require csh (for glob)
218 3) Use RPM_ARCH during configuration and installation for arch independence
This page took 0.134314 seconds and 4 git commands to generate.