]> git.pld-linux.org Git - packages/perl.git/blob - perl.spec
- added %changelog entry,
[packages/perl.git] / perl.spec
1 %define         perlver 5.005
2 %define         perlrel 03
3 %define         perlthread -thread
4
5 Summary:        Practical Extraction and Report Language
6 Summary(de):    Praktische Extraktions- und Berichtsprache 
7 Summary(fr):    Practical Extraction and Report Language (Perl)
8 Summary(pl):    Practical Extraction and Report Language (Perl)
9 Summary(tr):    Kabuk yorumlama dili
10 Name:           perl
11 Version:        %{perlver}_%{perlrel}
12 Release:        4
13 Copyright:      GPL
14 Group:          Utilities/Text
15 Group(pl):      Narzêdzia/Tekst
16 Source:         ftp://ftp.perl.org/pub/perl/CPAN/src/5.0/%{name}%{version}.tar.gz
17 Patch0:         perl-noroot_install.patch
18 Patch1:         perl-db1.patch
19 URL:            http://www.perl.org/
20 Requires:       csh
21 Buildroot:      /tmp/%{name}-%{version}-root
22
23 %description
24 Perl is an interpreted language optimized for scanning arbitrary text
25 files, extracting information from those text files, and printing reports
26 based on that information.  It's also a good language for many system
27 management tasks.  The language is intended to be practical (easy to use,
28 efficient, complete) rather than beautiful (tiny, elegant, minimal).
29
30 This version has support for threads compiled in.
31
32 %description -l de
33 Perl ist eine Interpreter-Sprache, die zum Durchsuchen beliebiger Text-
34 dateien, Extrahieren von Informationen aus diesen Dateien und Drucken von
35 auf diesen Informationen basierenden Berichten optimiert ist. Die Sprache
36 eignet sich außerdem für viele Systemverwaltungsaufgaben. Sie ist eher 
37 praktisch (einfache Anwendung,effizient, vollständig) als schön (winzig,
38 elegant, minimal).
39
40 %description -l fr
41 Perl est un langage interprété, optimisé pour filtrer des fichiers texte,
42 extraire des informations de ces fichiers, et imprimer des rapports basés
43 sur ces informations. C'est aussi un bon langage pour de nombreuses procédures
44 de gestion système. Ce langage se veut pratique (simple à utiliser, efficace,
45 complet) autant qu'agréable (conscrit, élégant, minimal).
46
47 %description -l pl
48 Perl jest jêzykiem przeznaczonym do skanowania plików tekstowych, wyci±gania
49 z nich informacji i drukowania raportu bazuj±cego na tych informacjach. Jest
50 równie¿ doskona³ym jêzykiem dla wielu narzêdzi do nadzoru systemu. Jêzyk ten
51 jest w zamierzeniu praktycznym (³atwym w u¿yciu, efektywnym, kompletnym) 
52 bardziej ni¿ piêkny ;) (skromny, elegancki, minimalny).
53
54 %description -l tr
55 Perl, metin dosyalarýný taramak, bu metin dosyalarýndan bilgi çýkarmak ve
56 bu bilgiye dayalý raporlar hazýrlamak icin geliþtirilmiþ bir yorumlamalý
57 dildir. Ayrýca pek çok sistem yönetimi görevleri için de yararlý yetenekleri
58 vardýr. Perl, güzel (ufak, zarif, minimum) olmaktan çok, pratik olmaya
59 yönelik (kullanýmý kolay, verimli, eksiksiz) olarak tasarlanmýþtýr.
60
61 %package -n     sperl
62 Summary:        Practical Extraction and Report Language (SUID root binary)
63 Summary(pl):    Practical Extraction and Report Language (SUID root binaria)
64 Group:          Utilities/Text
65 Group(pl):      Narzêdzia/Tekst
66 Requires:       %{name} = %{version}
67
68 %description -n sperl
69 Practical Extraction and Report Language (SUID root binary).
70
71 %description -n sperl -l pl
72 Practical Extraction and Report Language (SUID root binaria).
73
74 %prep
75 %setup  -q -n %{name}%{version}
76 %patch0 -p1
77 %patch1 -p1
78
79 %build
80 # this is gross
81 cat > config.over <<EOF
82 installprefix=$RPM_BUILD_ROOT/usr
83 test -d \$installprefix || mkdir \$installprefix
84 test -d \$installprefix/bin || mkdir \$installprefix/bin
85 installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
86 installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
87 installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
88 installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
89 installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
90 installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
91 installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
92 installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
93 EOF
94
95 sh Configure \
96         -des \
97         -Darchname=%{_target} \
98         -Dprefix=/usr \
99         -Dman1dir=/usr/share/man/man1 \
100         -Dman3dir=/usr/share/man/man3 \
101         -Dman3ext=3pm \
102         -Doptimize="$RPM_OPT_FLAGS" \
103         -Duseshrplib \
104         -Dusethreads \
105         -Dd_dosuid \
106         -Ud_setresuid \
107         -Ud_setresgid 
108
109 make
110
111 # Strip binaries (done now rather than at install)
112
113 strip {perl,suidperl,x2p/a2p}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT
118
119 make install
120 install utils/pl2pm $RPM_BUILD_ROOT/usr/bin/pl2pm
121
122
123 (cd /usr/include ;
124 PERL5LIB=$RPM_BUILD_ROOT/usr/lib/perl5 $RPM_BUILD_ROOT/usr/bin/perl \
125 $RPM_BUILD_ROOT/usr/lib/perl5/%{perlver}%{perlrel}/%{_target}%{perlthread} \
126 $RPM_BUILD_ROOT/usr/bin/h2ph \
127 -d $RPM_BUILD_ROOT/usr/lib/perl5/%{_target}/%{perlver}%{perlrel}/ \
128 *.h sys/*.h linux/*.h asm/*.h net/*.h netinet/*.h arpa/*.h )
129
130 ( cd $RPM_BUILD_ROOT/usr/lib/perl5/%{perlver}%{perlrel}/%{_target}%{perlthread}/
131
132 mv .packlist .packlist.old
133 sed "s|$RPM_BUILD_ROOT||g" < .packlist.old > .packlist
134 rm -f .packlist.old
135
136 mv Config.pm Config.pm.old
137 sed "s|$RPM_BUILD_ROOT||g" < Config.pm.old > Config.pm
138 rm -f Config.pm.old )
139
140 gzip -9fn $RPM_BUILD_ROOT/usr/share/man/man*/* \
141         README Change*
142
143 find $RPM_BUILD_ROOT/usr/lib/perl5 -name \*.so -exec strip --strip-unneeded {} \;
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %doc README.gz Change*
151
152 %attr(755,root,root) /usr/bin/a2p
153 %attr(755,root,root) /usr/bin/c2ph
154 %attr(755,root,root) /usr/bin/find2perl
155 %attr(755,root,root) /usr/bin/h2ph
156 %attr(755,root,root) /usr/bin/h2xs
157 %attr(755,root,root) /usr/bin/perl
158 %attr(755,root,root) /usr/bin/perl%{perlver}%{perlrel}
159 %attr(755,root,root) /usr/bin/perlbug
160 %attr(755,root,root) /usr/bin/perlcc
161 %attr(755,root,root) /usr/bin/perldoc
162 %attr(755,root,root) /usr/bin/pl2pm
163 %attr(755,root,root) /usr/bin/pod2html
164 %attr(755,root,root) /usr/bin/pod2latex
165 %attr(755,root,root) /usr/bin/pod2man
166 %attr(755,root,root) /usr/bin/pod2text
167 %attr(755,root,root) /usr/bin/pstruct
168 %attr(755,root,root) /usr/bin/s2p
169 %attr(755,root,root) /usr/bin/splain
170
171 %dir /usr/lib/perl5
172 %attr( - ,root,root) /usr/lib/perl5/*
173 /usr/share/man/man[13]/*
174
175 %files -n sperl
176 %attr(4755,root,root) /usr/bin/sperl%{perlver}%{perlrel}
177 %attr(4755,root,root) /usr/bin/suidperl
178
179 %changelog
180 * Sun May  9 1999 Piotr Czerwiñski <pius@pld.org.pl>
181   [5.005_03-4]
182 - FHS 2.0 compliant changes.
183
184 * Wed Apr 28 1999 Artur Frysiak <wiget@pld.org.pl>
185   [5.005_03-3]
186 - added db1 patch from RH 6.0
187
188 * Tue Apr 20 1999 Artur Frysiak <wiget@pld.org.pl>
189   [5.005_03-2]
190 - updated to 5.005_03
191 - changed source URL
192 - added -Dman3dir=/usr/man/man3 -Dman3ext=3pm -Duseshrplib to Configure
193 - corrected .packlist
194 - changed --strip-debug to --strip-unneeded
195 - gzipped %doc (instead bzipping2)
196 - commpiled on rpm 3
197
198 * Mon Oct 26 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
199   [5.005_02-2]
200 - added using $RPM_OPT_FLAGS during compile,
201 - added stripping modules,
202 - added URL,
203 - added sperl subpackage with suid perl binaries.
204
205 * Tue Sep 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
206   [5.005_02-1]
207 - updated to 5.005_02
208   (based on Ian Macdonald <ianmacd@xs4all.nl> spec files),
209 - install -d instead mkdir -p,
210 - added %defattr, but It's still unable to build from non root's account,
211 - man3 subdirectory moved to /usr/man/man3,
212 - minor modifications of spec file.   
213
214 * Mon Jun 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
215   [5.005_01-1]
216 - added pl translation,
217 - moved %changelog to end of spec,
218 - removed all old patches. 
219 - start at RH spec file.
This page took 0.059349 seconds and 4 git commands to generate.