]> git.pld-linux.org Git - packages/perl.git/blob - perl.spec
- downgraded to 5.005_03
[packages/perl.git] / perl.spec
1 %define         perlver 5.005
2 %define         perlrel 03
3 %define         perlthread -thread
4
5 Summary:        Practical Extraction and Report Language
6 Summary(de):    Praktische Extraktions- und Berichtsprache 
7 Summary(fr):    Practical Extraction and Report Language (Perl)
8 Summary(pl):    Practical Extraction and Report Language (Perl)
9 Summary(tr):    Kabuk yorumlama dili
10 Name:           perl
11 Version:        %{perlver}_%{perlrel}
12 Release:        1
13 Copyright:      GPL
14 Group:          Utilities/Text
15 Group(pl):      Narzêdzia/Tekst
16 Source:         ftp://ftp.perl.org/pub/perl/CPAN/src/5.0/%{name}%{version}.tar.gz
17 Patch0:         perl-noroot_install.patch
18 Patch1:         perl-DESTDIR.patch
19 URL:            http://www.perl.org/
20 Requires:       csh
21 Buildroot:      /tmp/%{name}-%{version}-root
22
23 %description
24 Perl is an interpreted language optimized for scanning arbitrary text
25 files, extracting information from those text files, and printing reports
26 based on that information.  It's also a good language for many system
27 management tasks.  The language is intended to be practical (easy to use,
28 efficient, complete) rather than beautiful (tiny, elegant, minimal).
29
30 This version has support for threads compiled in.
31
32 %description -l de
33 Perl ist eine Interpreter-Sprache, die zum Durchsuchen beliebiger Text-
34 dateien, Extrahieren von Informationen aus diesen Dateien und Drucken von
35 auf diesen Informationen basierenden Berichten optimiert ist. Die Sprache
36 eignet sich außerdem für viele Systemverwaltungsaufgaben. Sie ist eher 
37 praktisch (einfache Anwendung,effizient, vollständig) als schön (winzig,
38 elegant, minimal).
39
40 %description -l fr
41 Perl est un langage interprété, optimisé pour filtrer des fichiers texte,
42 extraire des informations de ces fichiers, et imprimer des rapports basés
43 sur ces informations. C'est aussi un bon langage pour de nombreuses procédures
44 de gestion système. Ce langage se veut pratique (simple à utiliser, efficace,
45 complet) autant qu'agréable (conscrit, élégant, minimal).
46
47 %description -l pl
48 Perl jest jêzykiem przeznaczonym do skanowania plików tekstowych, wyci±gania
49 z nich informacji i drukowania raportu bazuj±cego na tych informacjach. Jest
50 równie¿ doskona³ym jêzykiem dla wielu narzêdzi do nadzoru systemu. Jêzyk ten
51 jest w zamierzeniu praktycznym (³atwym w u¿yciu, efektywnym, kompletnym) 
52 bardziej ni¿ piêkny ;) (skromny, elegancki, minimalny).
53
54 %description -l tr
55 Perl, metin dosyalarýný taramak, bu metin dosyalarýndan bilgi çýkarmak ve
56 bu bilgiye dayalý raporlar hazýrlamak icin geliþtirilmiþ bir yorumlamalý
57 dildir. Ayrýca pek çok sistem yönetimi görevleri için de yararlý yetenekleri
58 vardýr. Perl, güzel (ufak, zarif, minimum) olmaktan çok, pratik olmaya
59 yönelik (kullanýmý kolay, verimli, eksiksiz) olarak tasarlanmýþtýr.
60
61 %package -n sperl
62 Summary:        Practical Extraction and Report Language (SUID root binary)
63 Summary(pl):    Practical Extraction and Report Language (SUID root binaria)
64 Group:          Utilities/Text
65 Group(pl):      Narzêdzia/Tekst
66 Requires:       %{name} = %{version}
67
68 %description -n sperl
69 Practical Extraction and Report Language (SUID root binary).
70
71 %description -n sperl -l pl
72 Practical Extraction and Report Language (SUID root binaria).
73
74 %prep
75 %setup  -q -n %{name}%{version}
76 %patch0 -p1
77 %patch1 -p1 -b .wiget
78
79 %build
80 # this is gross
81 cat > config.over <<EOF
82 installprefix=$RPM_BUILD_ROOT%{_prefix}
83 test -d \$installprefix || mkdir \$installprefix
84 test -d \$installprefix/bin || mkdir \$installprefix/bin
85 installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
86 installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
87 installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
88 installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
89 installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
90 installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
91 installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
92 installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
93 EOF
94
95 sh Configure \
96         -des \
97         -Dcc=gcc \
98         -Darchname=%{_target_platform} \
99         -Dprefix=%{_prefix} \
100         -Dman1dir=%{_mandir}/man1 \
101         -Dman3dir=%{_mandir}/man3 \
102         -Dman3ext=3pm \
103         -Doptimize="$RPM_OPT_FLAGS" \
104         -Duseshrplib \
105         -Dusethreads \
106         -Dd_dosuid \
107         -Ud_setresuid \
108         -Ud_setresgid 
109
110 make
111
112 # Strip binaries (done now rather than at install)
113
114 strip {perl,suidperl,x2p/a2p}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT
119
120 make install
121 install utils/pl2pm $RPM_BUILD_ROOT%{_bindir}/pl2pm
122
123 (cd %{_includedir} ;
124 LD_LIBRARY_PATH="%{_builddir}/%{name}%{perlver}_%{perlrel}" \
125 PERL5LIB=$RPM_BUILD_ROOT%{_libdir}/perl5 $RPM_BUILD_ROOT%{_bindir}/perl \
126 $RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}/%{_target_platform}%{perlthread} \
127 $RPM_BUILD_ROOT%{_bindir}/h2ph \
128 -d $RPM_BUILD_ROOT%{_libdir}/perl5/%{_target_platform}/%{perlver}%{perlrel}/ \
129 *.h sys/*.h linux/*.h asm/*.h net/*.h netinet/*.h arpa/*.h )
130
131 ( cd $RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}/%{_target_platform}%{perlthread}/
132
133 mv .packlist .packlist.old
134 sed "s|$RPM_BUILD_ROOT||g" < .packlist.old > .packlist
135 rm -f .packlist.old
136
137 mv Config.pm Config.pm.old
138 sed "s|$RPM_BUILD_ROOT||g" < Config.pm.old > Config.pm
139 rm -f Config.pm.old )
140
141 gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man*/* \
142         README Change*
143
144 find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.so -exec strip --strip-unneeded {} \;
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %doc README.gz Change*
152
153 %attr(755,root,root) %{_bindir}/a2p
154 %attr(755,root,root) %{_bindir}/c2ph
155 %attr(755,root,root) %{_bindir}/find2perl
156 %attr(755,root,root) %{_bindir}/h2ph
157 %attr(755,root,root) %{_bindir}/h2xs
158 %attr(755,root,root) %{_bindir}/perl
159 %attr(755,root,root) %{_bindir}/perl%{perlver}%{perlrel}
160 %attr(755,root,root) %{_bindir}/perlbug
161 %attr(755,root,root) %{_bindir}/perlcc
162 %attr(755,root,root) %{_bindir}/perldoc
163 %attr(755,root,root) %{_bindir}/pl2pm
164 %attr(755,root,root) %{_bindir}/pod2html
165 %attr(755,root,root) %{_bindir}/pod2latex
166 %attr(755,root,root) %{_bindir}/pod2man
167 %attr(755,root,root) %{_bindir}/pod2text
168 %attr(755,root,root) %{_bindir}/pstruct
169 %attr(755,root,root) %{_bindir}/s2p
170 %attr(755,root,root) %{_bindir}/splain
171
172 %dir %{_libdir}/perl5
173 %attr( - ,root,root) %{_libdir}/perl5/*
174 #%dir %{_libdir}/site_perl
175 #%attr( - ,root,root) %{_libdir}/site_perl/*
176 %{_mandir}/man[13]/*
177
178 %files -n sperl
179 %attr(4755,root,root) %{_bindir}/sperl%{perlver}%{perlrel}
180 %attr(4755,root,root) %{_bindir}/suidperl
This page took 0.058828 seconds and 4 git commands to generate.