]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
- group Development/Languages/PHP for -tests
[projects/template-specs.git] / perl.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests   # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    -
8 %define         pnam    -
9 Summary:        -
10 Summary(pl):    -
11 Name:           perl-
12 Version:        -
13 Release:        -
14 # note if it is "same as perl"
15 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 Patch0:         %{name}
19 # most of CPAN modules have generic URL (substitute pdir and pnam here)
20 #URL:           http://search.cpan.org/dist/%{pdir}-%{pnam}
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  -
24 %if %{with autodeps} || %{with tests}
25 BuildRequires:  perl-
26 BuildRequires:  perl-
27 %endif
28 Requires:       -
29 Provides:       -
30 Obsoletes:      -
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreq      'perl(anything_fake_or_conditional)'
35
36 %description
37
38 %description -l pl
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 %patch0 -p1
43
44 %build
45 # Don't use pipes here: they generally don't work. Apply a patch.
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make}
50 # if module isn't noarch, use:
51 # %{__make} \
52 #       OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 # note it's mostly easier to copy unpackaged filelist here, and run adapter over the spec.
69 # use macros:
70 #%%{perl_vendorlib}/...
71 #%%{perl_vendorarch}/...
72 %{_mandir}/man3/*
This page took 0.035419 seconds and 3 git commands to generate.