]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
f1a9673770793f029d358bc10ca8c3425af793b6
[projects/template-specs.git] / perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    -
7 %define         pnam    -
8 Summary:        -
9 Summary(de):    -
10 Summary(es):    -
11 Summary(fr):    -
12 Summary(pl):    -
13 Summary(ru):    -
14 Name:           perl-
15 Version:        -
16 Release:        -
17 # note if it is "same as perl"
18 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
19 Group:          Development/Languages/Perl
20 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
21 Patch0:         %{name}
22 URL:            -
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  -
26 Requires:       -
27 Provides:       -
28 Obsoletes:      -
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreq      'perl(anything_fake_or_conditional)'
33
34 %description
35
36 %description -l de
37
38 %description -l es
39
40 %description -l fr
41
42 %description -l pl
43
44 %description -l ru
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %patch0 -p1
49
50 %build
51 # Don't use pipes here: they generally don't work. Apply a patch.
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54
55 %{__make}
56 # if module isn't noarch, use:
57 # %{__make} \
58 #       OPTIMIZE="%{rpmcflags}"
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 # use macros:
75 #%%{perl_vendorlib}/...
76 #%%{perl_vendorarch}/...
77 %{_mandir}/man3/*
This page took 0.04904 seconds and 3 git commands to generate.