]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
9bbde857cf939d9a76535dcf3b223e1dcb7450d2
[projects/template-specs.git] / perl.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    -
7 %define pnam    -
8 Summary:        -
9 Summary(de):    -
10 Summary(es):    -
11 Summary(fr):    -
12 Summary(pl):    -
13 Summary(ru):    -
14 Name:           perl-
15 Version:        -
16 Release:        -
17 Epoch:          -
18 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
19 Group:          Development/Languages/Perl
20 Icon:           -
21 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
22 Patch0:         %{name}
23 URL:            -
24 BuildRequires:  perl-devel >= 5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  -
27 Requires:       -
28 Prereq:         -
29 Provides:       -
30 Obsoletes:      -
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreq      "perl(anything_fake_or_conditional)"
35
36 %description
37
38 %description -l de
39
40 %description -l es
41
42 %description -l fr
43
44 %description -l pl
45
46 %description -l ru
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50 %patch0 -p1
51
52 %build
53 # Don't use pipes here: they generally don't work. Apply a patch.
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56
57 %{__make}
58 # if module isn't noarch, use:
59 # %{__make} \
60 #       OPTIMIZE="%{rpmcflags}"
61
62 %{!?_without_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 # use macros:
77 #%%{perl_vendorlib}/...
78 #%%{perl_vendorarch}/...
79 %{_mandir}/man3/*
This page took 0.021434 seconds and 2 git commands to generate.