]> git.pld-linux.org Git - packages/perl.git/blob - perl.spec
0cd7f70f732fbf803934405afb7f52d0b068148c
[packages/perl.git] / perl.spec
1 %define         __find_provides %{_builddir}/%{name}-%{version}/find-perl-provides
2 %define         perlthread      -thread-multi
3 Summary:        Practical Extraction and Report Language
4 Summary(de):    Praktische Extraktions- und Berichtsprache 
5 Summary(fr):    Practical Extraction and Report Language (Perl)
6 Summary(pl):    Practical Extraction and Report Language (Perl)
7 Summary(tr):    Kabuk yorumlama dili
8 Name:           perl
9 Version:        5.6.0
10 Release:        11
11 Epoch:          1
12 License:        GPL
13 Group:          Utilities/Text
14 Group(fr):      Utilitaires/Texte
15 Group(pl):      Narzêdzia/Tekst
16 Source:         ftp://ftp.perl.org/pub/perl/CPAN/src/%{name}-%{version}.tar.gz
17 Patch0:         perl-noroot_install.patch
18 Patch1:         perl-nodb.patch
19 Patch2:         perl-DESTDIR.patch
20 Patch3:         perl-CPAN-1.58.patch
21 Patch4:         perl-find-provides.patch
22 Patch5:         perl-prereq.patch
23 Patch6:         perl-syslog.patch
24 Patch7:         perl-CGI-upload-tmpdir.patch
25 Patch8:         perl-LD_RUN_PATH.patch
26 Patch9:         perl-errno_h-parsing.patch
27 URL:            http://www.perl.org/
28 #Requires:      csh
29 Obsoletes:      perl-ANSIColor
30 Obsoletes:      perl-Devel-Peek
31 Obsoletes:      perl-DProf
32 Obsoletes:      perl-PodParser
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Perl is an interpreted language optimized for scanning arbitrary text
37 files, extracting information from those text files, and printing
38 reports based on that information. It's also a good language for many
39 system management tasks. The language is intended to be practical
40 (easy to use, efficient, complete) rather than beautiful (tiny,
41 elegant, minimal).
42
43 This version has support for threads compiled in.
44
45 %description -l de
46 Perl ist eine Interpreter-Sprache, die zum Durchsuchen beliebiger
47 Text- dateien, Extrahieren von Informationen aus diesen Dateien und
48 Drucken von auf diesen Informationen basierenden Berichten optimiert
49 ist. Die Sprache eignet sich außerdem für viele
50 Systemverwaltungsaufgaben. Sie ist eher praktisch (einfache
51 Anwendung,effizient, vollständig) als schön (winzig, elegant,
52 minimal).
53
54 %description -l fr
55 Perl est un langage interprété, optimisé pour filtrer des fichiers
56 texte, extraire des informations de ces fichiers, et imprimer des
57 rapports basés sur ces informations. C'est aussi un bon langage pour
58 de nombreuses procédures de gestion système. Ce langage se veut
59 pratique (simple à utiliser, efficace, complet) autant qu'agréable
60 (conscrit, élégant, minimal).
61
62 %description -l pl
63 Perl jest jêzykiem przeznaczonym do skanowania plików tekstowych,
64 wyci±gania z nich informacji i drukowania raportu bazuj±cego na tych
65 informacjach. Jest równie¿ doskona³ym jêzykiem dla wielu narzêdzi do
66 nadzoru systemu. Jêzyk ten jest w zamierzeniu praktycznym (³atwym w
67 u¿yciu, efektywnym, kompletnym) bardziej ni¿ piêkny ;) (skromny,
68 elegancki, minimalny).
69
70 %description -l tr
71 Perl, metin dosyalarýný taramak, bu metin dosyalarýndan bilgi çýkarmak
72 ve bu bilgiye dayalý raporlar hazýrlamak icin geliþtirilmiþ bir
73 yorumlamalý dildir. Ayrýca pek çok sistem yönetimi görevleri için de
74 yararlý yetenekleri vardýr. Perl, güzel (ufak, zarif, minimum)
75 olmaktan çok, pratik olmaya yönelik (kullanýmý kolay, verimli,
76 eksiksiz) olarak tasarlanmýþtýr.
77
78 %package -n sperl
79 Summary:        Practical Extraction and Report Language (SUID root binary)
80 Summary(pl):    Practical Extraction and Report Language (SUID root binaria)
81 Group:          Utilities/Text
82 Group(fr):      Utilitaires/Texte
83 Group(pl):      Narzêdzia/Tekst
84 Requires:       %{name} = %{version}
85
86 %description -n sperl
87 Practical Extraction and Report Language (SUID root binary).
88
89 %description -n sperl -l pl
90 Practical Extraction and Report Language (SUID root binaria).
91
92 %prep
93 %setup  -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98 %patch4 -p1
99 %patch5 -p1
100 %patch6 -p1
101 %patch7 -p1
102 %patch8 -p1
103 %patch9 -p1
104
105 for i in find-* ; do
106         mv $i $i.old
107         sed "s|FPPATH|%{_builddir}/%{name}-%{version}|g" < $i.old > $i
108         chmod 755 $i; rm -f $i.old
109 done
110
111 %build
112 # this is gross
113 cat > config.over <<EOF
114 installprefix=$RPM_BUILD_ROOT%{_prefix}
115 test -d \$installprefix || mkdir -p \$installprefix
116 test -d \$installprefix/bin || mkdir -p \$installprefix/bin
117 installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
118 installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
119 installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
120 installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
121 installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
122 installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
123 installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
124 installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
125 EOF
126
127 sh Configure \
128         -des \
129         -Dcc=%{__cc} \
130         -Darchname=%{_target_platform} \
131         -Dcccdlflags='-fPIC' \
132         -Dprefix=%{_prefix} \
133         -Dscriptdir=%{_bindir} \
134         -Dman1dir=%{_mandir}/man1 \
135         -Dman3dir=%{_mandir}/man3 \
136         -Dman3ext=3pm \
137         -Doptimize="$RPM_OPT_FLAGS" \
138         -Dusethreads \
139         -Uuselargefiles \
140 %ifarch sparc sparc64
141         -Ud_longdbl \
142 %endif
143         -Dd_dosuid
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT
150
151 %{__make} install
152 install utils/pl2pm $RPM_BUILD_ROOT%{_bindir}/pl2pm
153
154 ## Generate *.ph files with a trick (based on RH).
155
156 %{__make} all -f - <<EOF
157 PKGS    = glibc-devel gdbm-devel gpm-devel libgr-devel libjpeg-devel \
158         libpng-devel libtiff-devel ncurses-devel popt-devel \
159         zlib-devel binutils libelf e2fsprogs-devel pam-devel pwdb-devel \
160         rpm-devel
161 STDH    = \$(filter /usr/include/%%, \$(shell rpm -q --queryformat '[%%{FILENAMES}\n]' \$(PKGS)))
162 STDH    += \$(wildcard /usr/include/linux/*.h) \$(wildcard /usr/include/asm/*.h) \$(wildcard /usr/include/scsi/*.h)
163 GCCDIR  = \$(shell gcc --print-file-name include)
164 GCCH    = \$(filter \$(GCCDIR)/%%, \$(shell rpm -q --queryformat '[%%{FILENAMES}\n]' gcc))
165
166 LIBPATH = %{_builddir}/%{name}-%{version}
167 PERLLIB = $RPM_BUILD_ROOT%{_libdir}/perl5/%{version}
168 PERLBIN = $RPM_BUILD_ROOT%{_bindir}/perl
169 PERL    = LD_LIBRARY_PATH=\$(LIBPATH) PERL5LIB=\$(PERLLIB) \$(PERLBIN)
170 PHDIR   = \$(PERLLIB)/%{_target_platform}%{perlthread}
171 PHBIN   = $RPM_BUILD_ROOT%{_bindir}/h2ph
172 H2PH    = \$(PERL) \$(PHBIN) -d \$(PHDIR)/
173
174 all: std-headers gcc-headers
175
176 std-headers: \$(STDH)
177         cd /usr/include && \$(H2PH) \$(STDH:/usr/include/%%=%%)
178
179 gcc-headers: \$(GCCH)
180         cd \$(GCCDIR) && \$(H2PH) \$(GCCH:\$(GCCDIR)/%%=%%)
181
182 EOF
183
184 ## Fix paths
185 (
186 cd $RPM_BUILD_ROOT%{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
187 sed -e "s|$RPM_BUILD_ROOT||g" < Config.pm > Config.pm.new
188 mv -f Config.pm.new Config.pm
189 sed -e "s|$RPM_BUILD_ROOT||g" < .packlist > .packlist.new
190 mv -f .packlist.new .packlist
191 )
192
193 ## Fix permissions
194 find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.ph -exec chmod 444 {} \;
195 find $RPM_BUILD_ROOT%{_libdir}/perl5 -type d -exec chmod 755 {} \;
196
197 gzip -9nf README Change*
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %files
203 %defattr(644,root,root,755)
204 %doc README.gz Change*
205
206 %attr(755,root,root) %{_bindir}/a2p
207 %attr(755,root,root) %{_bindir}/c2ph
208 %attr(755,root,root) %{_bindir}/find2perl
209 %attr(755,root,root) %{_bindir}/h2ph
210 %attr(755,root,root) %{_bindir}/h2xs
211 %attr(755,root,root) %{_bindir}/perl
212 %attr(755,root,root) %{_bindir}/perl%{version}
213 %attr(755,root,root) %{_bindir}/perlbug
214 %attr(755,root,root) %{_bindir}/perlcc
215 %attr(755,root,root) %{_bindir}/perldoc
216 %attr(755,root,root) %{_bindir}/pl2pm
217 %attr(755,root,root) %{_bindir}/pod2html
218 %attr(755,root,root) %{_bindir}/pod2latex
219 %attr(755,root,root) %{_bindir}/pod2man
220 %attr(755,root,root) %{_bindir}/pod2text
221 %attr(755,root,root) %{_bindir}/podselect
222 %attr(755,root,root) %{_bindir}/pstruct
223 %attr(755,root,root) %{_bindir}/s2p
224 %attr(755,root,root) %{_bindir}/splain
225
226 %dir %{_libdir}/perl5
227 %attr( - ,root,root) %{_libdir}/perl5/*
228 #%dir %{_libdir}/site_perl
229 #%attr( - ,root,root) %{_libdir}/site_perl/*
230 %{_mandir}/man[13]/*
231
232 %files -n sperl
233 %defattr(644,root,root,755)
234 %attr(4755,root,root) %{_bindir}/sperl%{version}
235 %attr(4755,root,root) %{_bindir}/suidperl
This page took 0.08965 seconds and 2 git commands to generate.