]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
0124fa3e8dc433a81507f9b147ff14d68a9757b0
[projects/template-specs.git] / perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    -
7 %define         pnam    -
8 Summary:        -
9 Summary(de):    -
10 Summary(es):    -
11 Summary(fr):    -
12 Summary(pl):    -
13 Summary(ru):    -
14 Name:           perl-
15 Version:        -
16 Release:        -
17 # note if it is "same as perl"
18 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
19 Group:          Development/Languages/Perl
20 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
21 Patch0:         %{name}
22 URL:            -
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  -
26 %if %{with tests}
27 BuildRequires:  perl-
28 BuildRequires:  perl-
29 %endif
30 Requires:       -
31 Provides:       -
32 Obsoletes:      -
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreq      'perl(anything_fake_or_conditional)'
37
38 %description
39
40 %description -l de
41
42 %description -l es
43
44 %description -l fr
45
46 %description -l pl
47
48 %description -l ru
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52 %patch0 -p1
53
54 %build
55 # Don't use pipes here: they generally don't work. Apply a patch.
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58
59 %{__make}
60 # if module isn't noarch, use:
61 # %{__make} \
62 #       OPTIMIZE="%{rpmcflags}"
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 # use macros:
79 #%%{perl_vendorlib}/...
80 #%%{perl_vendorarch}/...
81 %{_mandir}/man3/*
This page took 0.032943 seconds and 3 git commands to generate.