]> git.pld-linux.org Git - packages/perl-prefork.git/blob - perl-prefork.spec
1b7a14f8a4366fd3ddd26cd3e46202009a0c0273
[packages/perl-prefork.git] / perl-prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    prefork
7 Summary:        prefork - optimize module loading across forking and non-forking scenarios
8 Summary(pl):    prefork - optymalizacja ³adowania modu³ów dla rozwidlonych i nierozwidlonych scenariuszy
9 Name:           perl-prefork
10 Version:        0.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/A/AD/ADAMK/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  040b340931bd8190b87c81130ea5f8d0
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.24-2
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The prefork pragma is intended to allow module writers to optimise
25 module loading for both scenarios with as little additional code as
26 possible.
27
28 The prefork.pm is intended to serve as a central and optional
29 marshalling point for state detection (are we running in procedural or
30 pre-forking mode) and to act as a relatively light-weight module
31 loader.
32
33 # %description -l pl
34 # TODO
35
36 %prep
37 %setup -q -n %{pdir}-%{version}
38
39 %build
40 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"%{pdir}")' \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes
58 %{perl_vendorlib}/*.pm
59 %{_mandir}/man3/*
This page took 0.063815 seconds and 3 git commands to generate.