]> git.pld-linux.org Git - packages/perl-namespace-autoclean.git/blob - perl-namespace-autoclean.spec
36869408463f57301fab6e7799090efc6633f074
[packages/perl-namespace-autoclean.git] / perl-namespace-autoclean.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    namespace
7 %define pnam    autoclean
8 Summary:        namespace::autoclean removes all imported symbols at the end of compile cycle
9 Summary(pl.UTF-8):      namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec cyklu kompilacji
10 Name:           perl-namespace-autoclean
11 Version:        0.29
12 Release:        1
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/namespace/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  39b38c776cd1f0ee03cc70781a2f2798
17 URL:            http://search.cpan.org/dist/namespace-autoclean/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-B-Hooks-EndOfScope >= 0.12
22 BuildRequires:  perl-Sub-Identify
23 BuildRequires:  perl-Test-Requires
24 BuildRequires:  perl-Test-Simple >= 0.88
25 BuildRequires:  perl-namespace-clean >= 0.20
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 When you import a function into a Perl package, it will naturally also
32 be available as a method.
33
34 The namespace::autoclean pragma will remove all imported symbols at
35 the end of the current package's compile cycle. Functions called in
36 the package itself will still be bound by their name, but they won't
37 show up as methods on your class or instances.
38
39 This module is very similar to namespace::clean, except it will clean
40 all imported functions, no matter if you imported them before or after
41 you used the pagma. It will also not touch anything that looks like a
42 method, according to Class::MOP::Class::get_method_list.
43
44 %description -l pl.UTF-8
45 namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec
46 cyklu kompilacji
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/namespace/*.pm
71 %{_mandir}/man3/*
This page took 0.360706 seconds and 3 git commands to generate.