]> git.pld-linux.org Git - SPECS.git/blob - perl-accessors.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-accessors.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 Summary:        accessors - create accessor methods in caller's package
6 Summary(pl.UTF-8):      accessors - tworzenie metod dostępu w pakiecie wywołującego
7 Name:           perl-accessors
8 Version:        1.01
9 Release:        1
10 # same as perl
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-authors/id/SPURKIS/accessors-%{version}.tar.gz
14 # Source0-md5:  fc764c9cbfd03762c0d4f8ffaabaecb0
15 URL:            http://search.cpan.org/dist/accessors/
16 BuildRequires:  perl-Module-Build >= 0.20
17 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.01}
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The accessors pragma lets you create simple accessors at compile-time.
25
26 This saves you from writing them by hand, which tends to result in
27 cut-n-paste errors and a mess of duplicated code. It can also help you
28 reduce the ammount of unwanted direct-variable access that may creep
29 into your codebase when you're feeling lazy. accessors was designed
30 with laziness in mind.
31
32 %description -l pl.UTF-8
33 Ten moduł pozwala na tworzenie prostych metod dostępowych w czasie
34 kompilacji. Oszczędza przed pisaniem ich ręcznie, co powodowałoby
35 błędy przy kopiowaniu i wklejaniu oraz bałagan w postaci powielonego
36 kodu. Może także zmniejszyć ilość niechcianych bezpośrednich dostępów
37 do zmiennych mogących się wkraść do kodu, kiedy programista jest
38 leniwy. accessors jest stworzony z myślą o lenistwie.
39
40 %prep
41 %setup -q -n accessors-%{version}
42
43 %build
44 perl Build.PL \
45         installdirs=vendor \
46         destdir=$RPM_BUILD_ROOT
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 ./Build install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README TODO
62 %{perl_vendorlib}/accessors.pm
63 %{perl_vendorlib}/accessors
64 %{_mandir}/man3/accessors*.3pm*
This page took 0.500023 seconds and 3 git commands to generate.