]> git.pld-linux.org Git - packages/perl-YAML-Syck.git/blob - perl-YAML-Syck.spec
e41794672fd611ee92cca54e201951a2c25a0c45
[packages/perl-YAML-Syck.git] / perl-YAML-Syck.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    YAML
7 %define         pnam    Syck
8 Summary:        YAML::Syck - fast, lightweight YAML loader and dumper
9 Summary(pl.UTF-8):      YAML::Syck - szybki, lekki moduł do wczytywania i zrzucania YAML-a
10 Name:           perl-YAML-Syck
11 Version:        0.71
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/YAML-Syck-%{version}.tar.gz
17 # Source0-md5:  c24b223c74504971b62cc7a94fee5f17
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-YAML >= 0.60
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module provides a Perl interface to the libsyck data
27 serialization library. It exports the Dump and Load functions for
28 converting Perl data structures to YAML strings, and the other way
29 around.
30
31 NOTE: If you are working with other language's YAML/Syck bindings
32 (such as Ruby), please set $YAML::Syck::ImplicitTyping to 1 before
33 calling the Load/Dump functions. The default setting is for preserving
34 backward-compatibility with YAML.pm.
35
36 %description -l pl.UTF-8
37 Ten moduł udostępnia perlowy interfejs do biblioteki serializacji
38 danych libsyck. Eksportuje funkcje Dump i Load do przekształcania
39 perlowych struktur danych na łańcuchy YAML i z powrotem.
40
41 Uwaga: jeśli pracujemy z dowiązaniami YAML/Sych dla innego języka
42 (np. Ruby), należy ustawić $YAML::Syck::ImplicitTyping na 1 przed
43 wywołaniem funkcji Load/Dump. Domyślne ustawienie jest dla zachowania
44 wstecznej zgodności z YAML.pm.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/YAML/Syck.pod
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %dir %{perl_vendorarch}/YAML
72 %{perl_vendorarch}/YAML/*.pm
73 %dir %{perl_vendorarch}/JSON
74 %{perl_vendorarch}/JSON/Syck.pm
75 %dir %{perl_vendorarch}/YAML/Dumper
76 %{perl_vendorarch}/YAML/Dumper/Syck.pm
77 %dir %{perl_vendorarch}/YAML/Loader
78 %{perl_vendorarch}/YAML/Loader/Syck.pm
79 %dir %{perl_vendorarch}/auto/YAML
80 %dir %{perl_vendorarch}/auto/YAML/Syck
81 %{perl_vendorarch}/auto/YAML/Syck/*.bs
82 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/Syck/*.so
83 %{_mandir}/man3/*
This page took 0.0404 seconds and 3 git commands to generate.