]> git.pld-linux.org Git - packages/perl-YAML-Syck.git/blob - perl-YAML-Syck.spec
86b64d824967af157c5ab9487dc234253e381ef7
[packages/perl-YAML-Syck.git] / perl-YAML-Syck.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    YAML
7 %define         pnam    Syck
8 Summary:        YAML::Syck - fast, lightweight YAML loader and dumper
9 Summary(pl.UTF-8):      YAML::Syck - szybki, lekki moduł do wczytywania i zrzucania YAML-a
10 Name:           perl-YAML-Syck
11 Version:        0.97
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  14c5459f8a09e98f8d11e0367e489787
18 URL:            http://search.cpan.org/dist/YAML-Syck/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-YAML >= 0.60
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a Perl interface to the libsyck data
28 serialization library. It exports the Dump and Load functions for
29 converting Perl data structures to YAML strings, and the other way
30 around.
31
32 NOTE: If you are working with other language's YAML/Syck bindings
33 (such as Ruby), please set $YAML::Syck::ImplicitTyping to 1 before
34 calling the Load/Dump functions. The default setting is for preserving
35 backward-compatibility with YAML.pm.
36
37 %description -l pl.UTF-8
38 Ten moduł udostępnia perlowy interfejs do biblioteki serializacji
39 danych libsyck. Eksportuje funkcje Dump i Load do przekształcania
40 perlowych struktur danych na łańcuchy YAML i z powrotem.
41
42 Uwaga: jeśli pracujemy z dowiązaniami YAML/Sych dla innego języka
43 (np. Ruby), należy ustawić $YAML::Syck::ImplicitTyping na 1 przed
44 wywołaniem funkcji Load/Dump. Domyślne ustawienie jest dla zachowania
45 wstecznej zgodności z YAML.pm.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make} \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/YAML/Syck.pod
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %dir %{perl_vendorarch}/YAML
73 %{perl_vendorarch}/YAML/*.pm
74 %dir %{perl_vendorarch}/JSON
75 %{perl_vendorarch}/JSON/Syck.pm
76 %dir %{perl_vendorarch}/YAML/Dumper
77 %{perl_vendorarch}/YAML/Dumper/Syck.pm
78 %dir %{perl_vendorarch}/YAML/Loader
79 %{perl_vendorarch}/YAML/Loader/Syck.pm
80 %dir %{perl_vendorarch}/auto/YAML
81 %dir %{perl_vendorarch}/auto/YAML/Syck
82 %{perl_vendorarch}/auto/YAML/Syck/*.bs
83 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/Syck/*.so
84 %{_mandir}/man3/*
This page took 0.068148 seconds and 3 git commands to generate.