]> git.pld-linux.org Git - packages/perl-YAML-Syck.git/blob - perl-YAML-Syck.spec
rebuild with perl 5.34.0
[packages/perl-YAML-Syck.git] / perl-YAML-Syck.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    YAML
6 %define         pnam    Syck
7 Summary:        YAML::Syck - fast, lightweight YAML loader and dumper
8 Summary(pl.UTF-8):      YAML::Syck - szybki, lekki moduł do wczytywania i zrzucania YAML-a
9 Name:           perl-YAML-Syck
10 Version:        1.34
11 Release:        2
12 License:        MIT
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  4aae72f5c06dccd6ed6ea9b029104183
16 URL:            https://metacpan.org/release/YAML-Syck
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides a Perl interface to the libsyck data
25 serialization library. It exports the Dump and Load functions for
26 converting Perl data structures to YAML strings, and the other way
27 around.
28
29 NOTE: If you are working with other language's YAML/Syck bindings
30 (such as Ruby), please set $YAML::Syck::ImplicitTyping to 1 before
31 calling the Load/Dump functions. The default setting is for preserving
32 backward-compatibility with YAML.pm.
33
34 %description -l pl.UTF-8
35 Ten moduł udostępnia perlowy interfejs do biblioteki serializacji
36 danych libsyck. Eksportuje funkcje Dump i Load do przekształcania
37 perlowych struktur danych na łańcuchy YAML i z powrotem.
38
39 Uwaga: jeśli pracujemy z dowiązaniami YAML/Sych dla innego języka
40 (np. Ruby), należy ustawić $YAML::Syck::ImplicitTyping na 1 przed
41 wywołaniem funkcji Load/Dump. Domyślne ustawienie jest dla zachowania
42 wstecznej zgodności z YAML.pm.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc COMPATIBILITY COPYING Changes
68 %{perl_vendorarch}/YAML/Syck.pm
69 %{perl_vendorarch}/JSON/Syck.pm
70 %dir %{perl_vendorarch}/YAML/Dumper
71 %{perl_vendorarch}/YAML/Dumper/Syck.pm
72 %dir %{perl_vendorarch}/YAML/Loader
73 %{perl_vendorarch}/YAML/Loader/Syck.pm
74 %dir %{perl_vendorarch}/auto/YAML/Syck
75 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/Syck/Syck.so
76 %{_mandir}/man3/JSON::Syck.3pm*
77 %{_mandir}/man3/YAML::Syck.3pm*
This page took 0.086947 seconds and 3 git commands to generate.