]> git.pld-linux.org Git - SPECS.git/blob - perl-XS-Parse-Keyword.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-XS-Parse-Keyword.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    XS
6 %define         pnam    Parse-Keyword
7 Summary:        XS::Parse::Keyword - XS functions to assist in parsing keyword syntax
8 Summary(pl.UTF-8):      XS::Parse::Keyword - funkcje XS pomagające w analizie składni słów kluczowych
9 Name:           perl-XS-Parse-Keyword
10 Version:        0.34
11 Release:        2
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/P/PE/PEVANS/XS-Parse-Keyword-%{version}.tar.gz
16 # Source0-md5:  ae441b1b439340efeb1b71b37d096e04
17 URL:            https://metacpan.org/dist/XS-Parse-Keyword
18 BuildRequires:  perl-ExtUtils-CChecker >= 0.11
19 BuildRequires:  perl-ExtUtils-ParseXS >= 3.16
20 BuildRequires:  perl-Module-Build >= 0.4004
21 BuildRequires:  perl-devel >= 1:5.14.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 %if %{with tests}
25 BuildRequires:  perl-Test2-Suite
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module provides some XS functions to assist in writing syntax
31 modules that provide new perl-visible syntax, primarily for authors of
32 keyword plugins using the PL_keyword_plugin hook mechanism.
33
34 %description -l pl.UTF-8
35 Ten moduł udostępnia funkcje XS pomagające w pisaniu modułów
36 składniowych, dostarczających składnię widoczną dla Perla, głównie dla
37 autorów wtyczek składniowych wykorzystujący mechanizm uchwytów
38 PL_keyword_plugin.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Build.PL \
45         config=optimize="%{rpmcflags}" \
46         destdir=$RPM_BUILD_ROOT \
47         installdirs=vendor
48 ./Build 
49
50 %{?with_tests:./Build test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 ./Build install
56
57 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/XS/Parse/Keyword/Keyword.bs
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %dir %{perl_vendorarch}/XS
66 %dir %{perl_vendorarch}/XS/Parse
67 %{perl_vendorarch}/XS/Parse/Infix
68 %{perl_vendorarch}/XS/Parse/Keyword
69 %{perl_vendorarch}/XS/Parse/Infix.pm
70 %{perl_vendorarch}/XS/Parse/Keyword.pm
71 %dir %{perl_vendorarch}/auto/XS
72 %dir %{perl_vendorarch}/auto/XS/Parse
73 %dir %{perl_vendorarch}/auto/XS/Parse/Keyword
74 %attr(755,root,root) %{perl_vendorarch}/auto/XS/Parse/Keyword/Keyword.so
75 %{_mandir}/man3/XS::Parse::Infix*.3pm*
76 %{_mandir}/man3/XS::Parse::Keyword*.3pm*
This page took 0.074009 seconds and 3 git commands to generate.