]> git.pld-linux.org Git - SPECS.git/blob - perl-XML-XSLT-Wrapper.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-XML-XSLT-Wrapper.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    XML
6 %define pnam    XSLT-Wrapper
7 Summary:        XML::XSLT::Wrapper - Consistent interface to XSLT processors
8 Summary(pl.UTF-8):      XML::XSLT::Wrapper - spójny interfejs do procesorów XSLT
9 Name:           perl-XML-XSLT-Wrapper
10 Version:        0.32
11 Release:        0.2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MU/MULL/XML-XSLT-Wrapper-%{version}.tar.gz
16 # Source0-md5:  d08350e5d6a45d5e42ac7ab5fa80fd45
17 URL:            http://search.cpan.org/dist/XML-XSLT-Wrapper/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # found from inline code
24 %define         _noautoreq      'perl(XML::Xalan::Transformer)'
25
26 %description
27 Provides a consistent interface to various XSLT processors. Tries each
28 of a supplied list of processors in turn until one performs a
29 successful transform. If no list is given, tries all the processors it
30 knows until one works. Does its best to fail gracefully whenever a
31 processor does not work for some reason.
32
33 %description -l pl.UTF-8
34 Ten moduł udostępnia spójny interfejs do różnych procesorów XSLT.
35 Próbuje każdy z dostarczonej listy procesorów aż których wykona
36 pomyślnie przekształcenie. Jeśli nie przekazano listy procesorów,
37 próbuje wszystkich znanych sobie procesorów. Usiłuje zachować się jak
38 najlepiej w przypadku niepowodzenia któregoś z procesorów.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README TODO
65 %dir %{perl_vendorlib}/XML/XSLT
66 %{perl_vendorlib}/XML/XSLT/*.pm
67 %{_mandir}/man3/*
68 %{_examplesdir}/%{name}-%{version}
This page took 0.71498 seconds and 3 git commands to generate.