]> git.pld-linux.org Git - SPECS.git/blob - perl-XML-XPath-Simple.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-XML-XPath-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    XPath-Simple
7 Summary:        XML::XPath::Simple - very simple interface for XPaths
8 Summary(pl.UTF-8):      XML::XPath::Simple - bardzo prosty interfejs do XPath
9 Name:           perl-XML-XPath-Simple
10 Version:        0.05
11 Release:        2
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  c97b04ecd031e7a27e5b8eb09a44928f
16 URL:            http://search.cpan.org/dist/XML-XPath-Simple/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple >= 0.18
21 BuildRequires:  perl-XML-Simple >= 1.08
22 %endif
23 Requires:       perl-XML-Simple >= 1.08
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 XML::XPath::Simple is designed to allow for the use of simple
29 Abbreviated XPath syntax to access values from a small XML document.
30 This module is not meant as a drop-in replacement for XML::XPath, and
31 doesn't support the entire W3C XPath Recommendation. This module is
32 meant as an easy and simple way to access XML data from small,
33 non-complex structures.
34
35 XML::XPath::Simple doesn't support documents that have elements
36 containing mixed content (text and tags), nor does it allow for the
37 walking of the tree structure, or the counting of elements. While this
38 module allows access to specific nodes using the position() function,
39 internally the module doesn't necessarially parse the XML structure in
40 any specific order, so position() calls may not return the value
41 expected.
42
43 %description -l pl.UTF-8
44 XML::XPath::Simple został zaprojektowany aby umożliwić użycie prostej
45 składni Abbreviated XPath do dostępu do wartości z małego dokumentu
46 XML. Ten moduł nie ma być pełnym zamiennikiem XML::XPath i nie
47 obsługuje całej rekomendacji XPath z W3C. Ma być prostym sposobem na
48 dostęp do danych XML z małych, nie złożonych struktur.
49
50 XML::XPath::Simple nie obsługuje dokumentów z elementami o mieszanej
51 treści (tekst i znaczniki), nie pozwala też na przemieszczanie po
52 strukturze drzewa ani liczenie elementów. O ile ten moduł pozwala na
53 dostęp do określonych węzłów przy użyciu funkcji position(),
54 wewnętrznie niekoniecznie analizuje strukturę XML-a w określonej
55 kolejności, więc wywołania position() mogą nie zwrócić takiej
56 wartości, jaką oczekiwano.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 %{perl_vendorlib}/XML/XPath/Simple.pm
81 %{_mandir}/man3/*
This page took 3.690562 seconds and 3 git commands to generate.