]> git.pld-linux.org Git - packages/perl-XML-TreePP.git/blob - perl-XML-TreePP.spec
- fixed %files
[packages/perl-XML-TreePP.git] / perl-XML-TreePP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    TreePP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::TreePP -- Pure Perl implementation for parsing/writing XML documents
9 Name:           perl-XML-TreePP
10 Version:        0.41
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3e999ac519163cf3cab70d3ee8d40b34
17 URL:            http://search.cpan.org/dist/XML-TreePP/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-libwww >= 5.802
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 XML::TreePP module parses an XML document and expands it for a hash tree.
28 This generates an XML document from a hash tree as the opposite way around.
29 This is a pure Perl implementation and requires no modules depended.
30 This can also fetch and parse an XML document from remote web server
31 like the XMLHttpRequest object does at JavaScript language.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} pure_install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50 cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/XML/*.pm
59 %{_mandir}/man3/*
60 %{_examplesdir}/%{name}-%{version}
This page took 0.026494 seconds and 4 git commands to generate.