]> git.pld-linux.org Git - packages/perl-XML-Stream.git/blob - perl-XML-Stream.spec
- complete
[packages/perl-XML-Stream.git] / perl-XML-Stream.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    Stream
8 Summary:        XML::Stream - XML streams interface for Perl
9 Summary(pl.UTF-8):      XML::Stream - interfejs do strumieni XML dla Perla
10 Name:           perl-XML-Stream
11 Version:        1.22
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ae09400fac17eaea4c9b12283db06881
18 Patch0:         %{name}-warnings.patch
19 URL:            http://search.cpan.org/dist/XML-Stream/
20 %{?with_tests:BuildRequires:    perl-Authen-SASL}
21 BuildRequires:  perl-Unicode-String >= 2.06
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreq      'perl(HTTP::ProxyAutoConfig)'
28
29 %description
30 This module provides you with access to XML Streams. An XML Stream is
31 just that. A stream of XML over a connection between two computers.
32
33 %description -l pl.UTF-8
34 Ten moduł daje dostęp do strumieni XML. Strumień XML jest po prostu
35 tym, co mówi nazwa - strumieniem XML po połączeniu między dwoma
36 komputerami.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 for i in Stream.pm Stream/*.pm Stream/*/*.pm; do
41         %{__perl} -pi -e 's/^(use 5.006_)0(01;)(.*)$/$1$2$3/' lib/XML/$i
42 done
43 %patch0 -p1
44
45 %build
46 echo -e "y\ny\ny\n" | %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         UNINST=0 \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README CHANGES INFO
65 %{perl_vendorlib}/XML/*
66 %{_mandir}/man3/*
This page took 0.035045 seconds and 4 git commands to generate.