]> git.pld-linux.org Git - packages/perl-XML-Stream.git/blob - perl-XML-Stream.spec
4f6b7a471d864889f7bf5b701d98d70136c12c08
[packages/perl-XML-Stream.git] / perl-XML-Stream.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    XML
7 %define pnam    Stream
8 Summary:        XML::Stream - XML streams interface for Perl
9 Summary(pl):    XML::Stream - interfejs do strumieni XML dla Perla
10 Name:           perl-XML-Stream
11 Version:        1.19
12 Release:        1
13 License:        LGPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2d6a5b66d02c79c86e54bc3e79e2c3b0
17 BuildRequires:  perl-Unicode-String >= 2.06
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _noautoreq      'perl(HTTP::ProxyAutoConfig)'
24
25 %description
26 This module provides you with access to XML Streams. An XML Stream is
27 just that. A stream of XML over a connection between two computers.
28
29 %description -l pl
30 Ten modu³ daje dostêp do strumieni XML. Strumieñ XML jest po prostu
31 tym, co mówi nazwa - strumieniem XML po po³±czeniu miêdzy dwoma
32 komputerami.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36 for i in Stream.pm Stream/*.pm Stream/*/*.pm; do
37         %{__perl} -pi -e 's/^(use 5.006_)0(01;)(.*)$/$1$2$3/' lib/XML/$i
38 done
39
40 %build
41 echo -e "y\ny\ny\n" | %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         UNINST=0 \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README CHANGES INFO
60 %{perl_vendorlib}/XML/*
61 %{_mandir}/man3/*
This page took 0.044603 seconds and 2 git commands to generate.