]> git.pld-linux.org Git - packages/perl-XML-Stream.git/blob - perl-XML-Stream.spec
- more tests BRs
[packages/perl-XML-Stream.git] / perl-XML-Stream.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    Stream
8 Summary:        XML::Stream - XML streams interface for Perl
9 Summary(pl.UTF-8):      XML::Stream - interfejs do strumieni XML dla Perla
10 Name:           perl-XML-Stream
11 Version:        1.24
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  62717494479cba3746bfeab73d2f955c
18 Patch0:         %{name}-warnings.patch
19 URL:            http://search.cpan.org/dist/XML-Stream/
20 BuildRequires:  perl-Unicode-String >= 2.06
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Authen-SASL
25 BuildRequires:  perl-Encode
26 BuildRequires:  perl-MIME-Base64
27 BuildRequires:  perl-Test-Simple >= 0.92
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreq      'perl(HTTP::ProxyAutoConfig)'
33
34 %description
35 This module provides you with access to XML Streams. An XML Stream is
36 just that. A stream of XML over a connection between two computers.
37
38 %description -l pl.UTF-8
39 Ten moduł daje dostęp do strumieni XML. Strumień XML jest po prostu
40 tym, co mówi nazwa - strumieniem XML po połączeniu między dwoma
41 komputerami.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45 for i in Stream.pm Stream/*.pm Stream/*/*.pm; do
46         %{__perl} -pi -e 's/^(use 5.006_)0(01;)(.*)$/$1$2$3/' lib/XML/$i
47 done
48 %patch0 -p1
49
50 %build
51 echo -e "y\ny\ny\n" | %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         UNINST=0 \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README CHANGES INFO
70 %{perl_vendorlib}/XML/*
71 %{_mandir}/man3/*
This page took 0.086317 seconds and 3 git commands to generate.